Resolved: [Bug Report] Castlevania: Lament of Innocence [NTSC]
Castlevania: Lament of Innocence [1xDVD5,NTSC-U]

PCSX2 version: svn 1019-18xx
Cpu options: EERec, VU recompilers, MTGS on [no static conf., tested with various comb.]
Advanced settings: initial: default (can variate, doesn't affect the game actually)
Speedhacks: initial: none (can be any)
GFX: GSdx 0.1.15 SSE41, DX10 HW, no interlacing
GFX2: ZeroGS 0.97.1 pg/original
Sound: SPU2-X 1.1.0 (@r1019)
Control: Lilypad @ r1019
CD/DVD plugin: Linuz/Pg Iso CDVD (@r1019)

Game works pretty fine except some places/locations where FPS drops significally (like the first one) and speedhacks doesn't helps at all. I still not so far in game, so, can't tell how many such places/locations.

Noticed bugs/glitches:
1. Incorrect shadows: GSdx bug, reported here, in GSdx thread. Also, issue does not appears in Software mode.
2. Incorrect light/polygons:

^- that can be partially fixed by mircoVU or completely by disabling VU0 rec (which leads to great FPS drop sometimes):


Sponsored links

The second bug can be solved by enabling microVU1-0 and disabling SuperVU0 (but not 1).
Shadows still broken.
you know microvu0 doesnt work unless supervu0 is ticked, right?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
I mean that with svu1-mvu1 fps doesn't drops so significally.
But yeah, this difference can notice only people with ***** PC, like me. I'm happt for another +1-3 fps >_>
Ok yeah, then this is the same bug as reported by someone else some months ago. The actual solution is to use the VU0 interpreter, which typically isn't very cpu intensive. Using the VU1 interpreter is much slower. Not sure exactly why it happens though. Could be a pipeline issue or could be a more fundamental floating point math issue -- both are calculated differently under the VU interpreters.
Jake Stine (Air) - Programmer - PCSX2 Dev Team
Hmm... looks like I was wrong. There is still some places (the whole locations) where FPS drops from 60 to 20-25 and PCspecs/speedhacks doesn't matter.
PCSX2 version: svn 1678 (also test in PCSX2 0.9.6)
Cpu options: default
Advanced settings: initial: default
GFX: GSdx (latest update), DX9
Sound: SPU2-X 1.1.0 (latest update)
Control: Lilypad (latest update)
CD/DVD plugin: CDVD 0.1.0

Game works pretty fine except this evil twin just stand there and won't do anything.


[Image: 6th56f.jpg]
So I should download PCSX2 r1473 for this unfreeze issue of evil twin ?

If so, where can I download this version ? or is r1473 a GSdx version? I am confused.
Quote:So I should download PCSX2 r1473 for this unfreeze issue of evil twin ?
Are you asking me? Ok, I allow you to download it. You have my permission now.

Quote:If so, where can I download this version ?
tbh I have no clue.

Users browsing this thread: 1 Guest(s)