Resolved: [Bug Report]Champions of Norrath [NTSC-U] [SLUS-20565][Bug Report]
[Bug Report]Champions of Norrath [NTSC-U] [SLUS-20565][Bug Report]

# PCSX2 version: Official v0.9.6 release; beta r1888
# CPU options: EErec on| VUrec0 and VUrec1 on |MTGS on|Multi threading GS Mode | Frame Limiting: Limit |
# Plugins used:
GSdx 0.1.14 [MSVC 15,SSSE3](software,dx10),:1280x1224 | Blend tff |SW rendering threads:2 | Texture Filtering | Wait Vsync
spu2-X 1.1.0: Linear | XAudio2 |
Gigaherz Cdvdrom 0.7.0:
LilyPad 0.9.9
-Advanced OptionsLaughefault


Windows: Microsoft Windows XP Home Edition 5.1.2600 Service Pack 3
Memory (RAM): 4095 MB
CPU Info: Intel® Core™2 Quad CPU Q6700 @ 2.66GHz
CPU Speed: 2663.8 MHz
Sound card: Speakers (Creative SB X-Fi)- Creative Xtremegamer
Display Adapters: NVIDIA GeForce GTX 280 | NVIDIA GeForce GTX 280 | RDPDD Chained DD | RDP Encoder Mirror Driver | RDP Reflector Display Driver
Network Adapters: NVIDIA nForce 10/100/1000 Mbps Ethernet #2 | NVIDIA nForce 10/100/1000 Mbps Ethernet | VMware Virtual Ethernet Adapter for VMnet8
CD / DVD Drives: E: TSSTcorpDVD+-RW TS-H553A
Mouse: 16 Button Wheel Mouse Present
Hard Disks: C: 30.2GB | D: 435.5GB
Hard Disks - Free: C: 3.8GB | D: 254.5GB
Manufacturer: Phoenix Technologies, LTD
Product Make: XFX nForce 790i Ultra 3-Way SLI
BIOS Info: AT/AT COMPATIBLE | 09/10/08 | XFX79U - 42302e31
Motherboard: XFX XFX nForce 790i Ultra 3-Way SLI

# Description: Game will boot but During intro credits the video will freeze. The background music will play on until the end of that intro segment. Once that video ends. PCSX2 will freeze. The DVD appears to read fine and no errors apear in the Console. It simply stops.
[Image: Deadlysin-2.jpg]

Sponsored links

[Image: Deadlysin-2.jpg]
Bump for what?
You made the report and it will be looked after... whenever the devs want.

You also forgot to try the latest beta.

Edit: uhhh multiple useless bumps...
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Have tried the game on pcsx2-r1736, and r1888.

I can pretty much just confirm what Demon002 says, the game boots, and allows you to select language(tried all), then after a bit of loading the game freezes for a small while before the emulator goes 'not responding'. No error in the console as far as I can tell. The error always occurs at the same position, you can't miss recreating it.

Not sure if it's important, uploaded a screen shot where the game stops:

Emulator settings:
Graphics: GSdx 1873 (MSVC 15.00, SSE2) 0.1.15
--- Renderer Direct3D10(Software) <- (With hardware, I get half screen)
Sound: SPU2-X 1.2.0
Controller: LilyPad svn(r1853) 0.10.0
Cdvdrom: Linuz Iso CDVD 0.9.0
Dev9: DEV9null Driver 0.4.0
Bios: Europe v01.60(04/10/2001)Console

My system:
OS: Windows Vista 64bit (Home Premium)
CPU: Intel Core 2 Duo CPU T9400 @ 2.53GHz
Memory: 4096 MB DDR2 RAM
Graphics: Nvidia GeForce 9600M GT
#5 one can say..."it works" Sad

Has no one an idea?
Because it doesn't. That's why this is called the bug report forum.
[Image: newsig.jpg]
Well, if it is any useful piece of information, 'Baldurs Gate', which also runs on the Snowblind engine ( just like Champions of Norrath + RTA ), seems to have the same problem. So there is most likely a connection with the engine.

Now a question would be if the game freezes because of the start-up process, or if the entire game would be broken, even if we were to fix the start-up.

I'd really love to see 'Champions' and 'Return to Arms' work on the PCSX2.
I actually managed to get the thing to run, but the textures were everywhere, missing floor, characters poly's are green, all kinds of stuff.
to get it to run, I enabled both microvu in the beta rev.
Thanks to devilbless, I've made some progress with 'Return to Arms' which is my favourite.

As long as no other settings are wrong, the main solution here seems to be that by enabling microVU0 and microVU1 in the CPU config, you can finally make it to the main menu, and all the way into the game.

From here on, problems unfortunately, but not unexpectedly appear... By using graphic plugin 'GSdx 2693 (MSVC 15.00, SSSE3) 0.1.16' the game would crash(with the extremely useful error message '!@#$') when moving a particular distance from where the character starts out(does not happen if just moving character in a small circle). The same would happen also if moving the camera down. I assumed this a graphical problem, and tried using ZeroGS 0.97.1. The problem does no longer occur, but for all settings I've tried with this plugin, only half the screen appears. The half-screen issue is something that to my understanding happens on all games using the Snowblind engine, when using this plugin. Also making this plugin useless is that when the camera is moving around, which of course happens to be nearly all the time, the FPS drops to less than 1.

Problem summary:

Half the screen is black.
Some graphical oddities and artifacts.
Horrible framerate.
GSdx(SSE2, SSE41, and SSSE3): Software renderer prevents half black screen.
Some graphical oddities and artifacts.
Game crashes at gameplay(probably something graphical when moving camera).

I can't say for sure, but I believe the graphic plugin is the issue here.

I'm hoping that some programmers can have a look at this game, perhaps a solution could be made.
With the latest svn version (r4832) things are still the same. Although when you get into game and change the view to a closer one the dev console gets spammed with "!@#$". Seriously, that's what it says.

Users browsing this thread: 1 Guest(s)