Thread Rating:
  • 5 Vote(s) - 3.4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolved: [Bug Report]Champions of Norrath [NTSC-U] [SLUS-20565][Bug Report]
#31
i have the problem of where i get a half screen, the left half runs fine. the right half however will be pure black until i click new game, then all kinds of mixed colors will just start forming and worms its away across the right side.

Sponsored links

#32
Yeh, did you read any of this thread? also this isnt a support section..
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#33
Well sudonim made a lot of progress relating to this bug in r5404. The game seems to run fine (in software mode, half the screen is still missing) until you can actually move your character. When the camera moves it causes GSDX to run out of video memory and start disabling texturing which causes flickering. Once the camera is done moving everything goes back to normal.
#34
PCSX2 Version: PCSX2 1.3.0.r0 - compiled on Feb 19 2014 (for some reason when you build with yaourt -S pcsx2-svn the version gets screwed up)
CPU Options: All option set to default
Preset: "Safest"
Pluggins: DSdx (GCC 4.8.2, SSE2) 0.1.16 [libGSdx-0.1.16]; SPU2-X 2.0.0 [libspu2x-2.0.0]
System: AntergOS 64bit (kernel: 3.13.6-1-ARCH)

I only tested software mode since the game is unplayable in hardware mode.

When in the leveling menu, potentially before that, when you "mouse over" a skill, it gets stuck. You can neither move the cursor, nor select the skill (so you can't work around it).

Last I played this game (in Windows about a month ago with the official 1.2.1 release) This was not an issue. Furthermore, I've never played this game in Linux before.

No error messages were given in the log.

I tried uploading the memory, but I got an angry red message stating that that sort of file is prohibited from being uploaded.

[edit] I had all logging disabled. I renabled it:

Code:
Protected page @ 0x001b6
Pagesplit @ 001B6FC4 : size=15 insts
Protected page @ 0x001b7
Pagesplit @ 001AFFFC : size=1 insts
Protected page @ 0x001b8
Protected page @ 0x001b9
Pagesplit @ 001B7FF8 : size=2 insts
Protected page @ 0x00101
Pagesplit @ 00309FF4 : size=3 insts
Protected page @ 0x001b5
Protected page @ 0x001bd
Pagesplit @ 001BEF50 : size=44 insts
Protected page @ 0x001bf
Protected page @ 0x001c0
Pagesplit @ 001BFFF8 : size=2 insts
still running 1 min

Not sure if any of that is meaningful, but I figure its best to post it.

[edit2] I just tried with the the latest svn (PCSX2 1.3.0.r5929 - compiled on Mar 22 2014, building with yaourt -G pcsx2-svn et al results in the correct name) and I'm still getting the same error.

[edit3] The problem also persists in pcsx2-1.2.2-2, which I presume to be the official build.

[edit4] Still broken in r5931.

[edit5] I've confirmed not only that its broken in r5932 (I'm thinking I should stop hoping for a fix), but also that its not just when leveling that this is an issue. You should be able to reproduce the error simply by creating a new character, hitting the "select" key and going all the way to he right using "R1" and placing the cursor over one of the circles.
i7 4930k @4.3, 4x4 GB RAM @2133 (15-15-15-27, quad channel), EVGA 570 @stock, Arch 64b.
#35
I have confirmed that this issue is not an issue in Windows. Whatever is causing this problem is Linux specific.
i7 4930k @4.3, 4x4 GB RAM @2133 (15-15-15-27, quad channel), EVGA 570 @stock, Arch 64b.
#36
The bug seems to have been fixed. I just tested it with "PCSX2 1.3.0-20150119101212 - compiled on Jan 22 2015"
i7 4930k @4.3, 4x4 GB RAM @2133 (15-15-15-27, quad channel), EVGA 570 @stock, Arch 64b.
#37
Thank you for your report.
This bug report has now been marked as Resolved since it has been fixed on our code base.

This thread will now be closed and moved to the resolved bug reports subforum.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction




Users browsing this thread: 1 Guest(s)