Resolved: [Bug Report] FFX PAL Battle Graphics Flip [Linux 0.9.6]
#Attempted to run on beta 1736, does not run.
#All listed configuration is in the attachment "Settings.jpg"
#Other graphics plugins do not load on my PC.
#Screenshot.jpg shows the problem.

Heh. It's been an uphill battle so far - I have only been using PS2X for a little while now. Thought that the problem would be best given it's own thread since I've not found similar in another. The blurring I found answers to in another thread answered by Shadow Lady, and it's not what I'm looking for information about.

I'm also aware that some people are having troubles with the PAL version of FFX. In this aim I'll be ripping the bios on one of my NTSC PS2s later today, and then ripping the copy of FFX that came with it. But JIC the issue is still present in the NTSC version, can anyone help me troubleshoot this glitch? It has no effect on the game, other than looking silly... The graphics are completely normal for both the cinematics and the regular non-combat interface.

When the blur comes through for combat, it dips into the lower 30s for FPS and then gets distorted - I get a "split mirror image" (top of the screen is reflected over the bottom half of the screen), followed by the graphics flipping as you can see. Interestingly, the UI is still in it's normal place...

I've also tested it out with both the CD and the PS2 I did the rips from; the game runs fine without issues - and I've verified that the bios and cd ripped properly. If any additional information is needed, please let me know.

Thanks for any help you may provide - the game runs fine otherwise (nVidia GeForce 9400 GT for graphics), so please don't post about how I need to overclock - the game's running fine without it.

Attached Files Thumbnail(s)

Sponsored links

hahahah Laugh turn your monitor upside down. Smile
Try changing in Config->Advanced round mode to negative or clamping to full
[Image: newsig.jpg]
Both miss. It's ZeroGS known issue. Use ZZogl instead.
(04-25-2010, 05:43 PM)Zeydlitz Wrote: Both miss. It's ZeroGS known issue. Use ZZogl instead.

Third miss.

1) Lulz on the monitor offer =P
2) Already done - though thanks for the suggestion, forgot to post the advanced tab image.
3) Already told you that ZeroGS is the only graphics plugin that's letting me load anything - if you can offer ZZogl that works, I'll use it. Until then, tried it and it didn't work. Moved on. Also posted as "#Other graphics plugins do not load on my PC" in my commentary, though in 20/20 hindsight that's not very descriptive.

FTR: Tried ZZogl 0.18.165 as the most current linux build AFAIK - if that's not, a link to the more recent would be great. I'll give it another whirl.
And just found the latest ZZogl -

Unfortunately, it didn't work. 0.9.6 and 1736beta builds; not familiar enough with the terminal to get pcsx2 to load from there, so I don't have an error log. Doesn't leave a hanging PCSX2, just terminates without visible error.

As a quick edit update: Same issue with US build ROM and NTSC disc D= So I think it might be the ZeroGS - but with ZZogl not working, I'm at a loss.
Give me a ZZogl picture, than I could tell you something. And last is 214, it may be some help. To get a log look into logs subdirectory -- there is gsLog.txt file. Mirrored image is ZeroGS bug, you could not solve it by anu other means than using ZZogl.
If I could get a ZZogl picture, I'd show you - but I suspect if I had a ZZogl picture, the problem would be over. And you wouldn't happen to know where I could get 214, then? I'll give that one a go.

As for this thread in general, think this should be moved to plugins support?
Thank you for your report.
This bug report has now been marked as Resolved since it has been fixed on our code base.

This thread will now be closed and moved to the resolved bug reports subforum.

Users browsing this thread: 1 Guest(s)