Resolved: Bug Report: Growlanser Heritage of War (Menu Freezing)
CPU: AMD Athlon II X3 445
GPU: GeForce 650 Ti
Windows 10, PCSX2 1.4.0
GS Plugin: GSDX HW
EE Cycle Rate 0, VU Cycle Stealing 0, INTC Spin Detection on, Enable Wait Loop Detection on, Enable Fast CDVD off,
mVU Flag Hack on, MTVU on.
GS Settings: Adapter: Default Hardware Device, Renderer: OpenGL (Hardware), Interlacing: Auto, Allow 8 Bit Textures: on, Internal Resolution: Native, Texture Filtering: Bilinear (PS2), Anisotropic Filtering: Off, CRC Hack Level: Full, Enable HW hacks: ON (MSAA 0x, Skipdraw 0, Half Pixel Offset ON, Align Sprite: Off, Wild Arms Offset: Off, Preload Data Frame: On, Round Sprite: Off, Sprite: Off, TC Offset X: 0, TC Offset Y: 0), Hardware Depth: On, Accurate Date: Off, Blending Unit Accuracy: High.  Shader configuration not altered.

I think that should be most to all relevant information... So, I've been playing Growlanser: Heritage of War on emulator, since my PS2's disc reader is brocked, and I've been able to play with minor issue up to the beginning of Fanille's scenario.  I had originally encountered the sprite texture depth issue, and found the fix for it by turning on both Hardware Depth and Preload Data Frame, but I haven't seen this brought up before, so I wanted to bring it here.

I've recruited Krious and Elena, and immediately upon both being in my party and leaving town, any time I attempt to bring up the menu or even enter combat (I've tried holding R2 and running past a monster and get the same results), the sounds will play/change as appropriate, but the game will otherwise freeze, sometimes causing the audio to dramatically slow or glitch out, sometimes just leaving it to play cheerily.  The menu bar informs me that the emulator itself is still happily running at 60 FPS, but the GS usage abruptly drops to ~1%.  I've tried switching to software mode, and Gs3D11 and Gs3D9 with no luck whatsoever.  Fooling with graphics or speed hacks doesn't seem to help either.  I've tried disabling MTVU and playing with the blend accuracy, and I don't know enough about the shader or TC offset to fuss with it in any meaningful way.  Changing the texture filtering to forced bilinear caused ugly lines to appear all over the screen and still caused the game to crash.  Does anyone know what's happening?  Is it possibly a corrupt ISO? (My computer takes an ungodly time to rip ISO's from disc, so I downloaded a backup, but I could just play direct from disc if absolutely necessary)  I'm not really tech minded in the "graphics rendering" sense, so I'm not really sure how to approach this Sad

I should note that this *wasn't* happening before this scenario. Seldous, Randall and Rockbein's scenarios played out in full without this happening except once early in Seldous's scenario, before I had fixed the texture depth thing (I had assumed it to be linked, but I guess not?)

Sponsored links

Piracy is not supported here. Please remove the backup and try the game from your own disc or rip. And please share the version of the game you're playing (PAL Europe, NTSC-U America, NTSC-J Japan).

As for a possible solution you could try going to Config > Emulation Settings > EE/IOP tab, and setting Round Moude to Positive. This seems to have resolved a similar freeze.
Apologies. It was my understanding that as long as you owned the game legally, having an ISO of the disc on your computer was perfectly legal, but I didn't exactly do extensive research on the federal and state laws surrounding it. I'll remove the ISO promptly until I can confirm one way or another with certainty.

I'm using the NTSC-U version of the game. I'll dig out the disc from storage sometime tomorrow and try it as is, to see if it's a corruption issue, and with the adjustment you mentioned, in case it's an emulation issue.
We recommend using Imgburn to make an ISO of your disc. It is perfectly legal for you to have an ISO of your disc, but it must come from your disc and not the internet Smile
[Image: ref-sig-anim.gif]

Some reading which could help or not
EDIT: You can disregard the latter 2/3 of this message: I got in touch with a friend who had purchased the game (on my advice, apparently) a few years back, and is willing to lend me the physical disc and a resurfacer he had from his time as a GameStop employee, in hopes of repairing my disc (although I'm not suuuper hopeful about that, the scratch on mine actually appears white on the black DVD face :/)  So yeah, I'll be testing these fixes as soon as I'm once again in possession of a usable copy of the game.

Thank you all for your responses.  In response to the last one, I actually ended up reading that thread while trying to fix the depth issues, which I had successfully dealt with (Thanks to the advice on this thread, actually).  I'm not sure what's causing this new issue, but it's a moot point, since the disc I had in storage was damaged (The case ended up crushed in the box I was keeping it in, and the disc got scratched beyond repair), and is unusable.  I'll have to re-acquire the game before I'm ready to tackle this issue.  For the time being, feel free to push this over to the Closed bin, since I can't test or take action on any of the fixes suggested here anyways.

In other news, I've learned not to store PS2 games in the garage ._.
OK!  Got the clean disc, threw it in and fired it up.  First thing I tried was just running it with no fixes from the clean disc, same freeze.  Sad.  Changing the Recompiler Round Mode to Positive didn't help either.  I tried a few different emulation modes before becoming curious and pulling up the console.  Pushed the game into a window and watched the console while I hit the menu button, and the results were immediate:

sceGsSyncPath: VIF1 does not terminate
sceGsSyncPath: VIF1 does not terminate
sceGsSyncPath: VIF1 does not terminate
sceGsSyncPath: DMA Ch.2 does not terminate
Vif1: Unknown VifCmd! [a]
Vif1: Unknown VifCmd! [b]
Vif1: Unknown VifCmd! [b]
Vif1: Unknown VifCmd! [b]
Vif1: Unknown VifCmd! [a]
Vif1: Unknown VifCmd! [8]
Vif1: Unknown VifCmd! [16]
sceGsSyncPath: DMA Ch.1 does not terminate

The last 4 lines, starting sceGsSyncPath: DMA Ch.1 does not terminate down to the end, repeats indefinitely until I close the emulation.  So it looks like whatever Vif1 is, is what's initially throwing a wrench into the works.  Some kind of runaway process or something?  I'm not sure.  The fixes I saw for this game were all for an older version of PCXS2, and it was apparently stable on them... I wish I had a second box using a different CPU or video card to see if I could reproduce this error elsewhere, or if there's something screwed up with windows or my graphics driver that is interfering... but I've run most or all of the configurations from the EE/IOP page that I can think of to no avail.

When the crash occurs, my process load goes from about EE: 35% / GS 35% / VU 10% to EE 80% / GS 0-1% / VU 0%, which further makes me think that there's some kind of runaway process or code error behind this, and that it's not a rendering issue of any sort, but most of this is sorta armchair knowledge: I'm not familiar at all with how PCSX2 works, so I'm mostly making educated guesses on the meaning of these numbers.
Don't worry. This is a somewhat common error - still happens on a few games. Usually has nothing to do with your hardware as it's an internal issue
(09-22-2016, 05:14 AM)CK1 Wrote: Don't worry. This is a somewhat common error - still happens on a few games. Usually has nothing to do with your hardware as it's an internal issue

In this case, I was more thinking I'd like to have a different setup to see if it's a driver conflict of some sort, or a quirk of how my CPU interacts with the emulator or something, or what. I've not seen others report this sort of issue at all (and it's only cropped up for me after 3 full scenarios of the menu working fine), so I was thinking it might have been some kind of DirectX error or a GPU driver conflict or something, rather than something inherently wrong with the way the emulator handles this particular game. Generally when I have an enormous game ending crash that's the emulator's fault directly, someone else out there has experienced it too, and I can usually toy with settings (or realize my hardware isn't up to snuff) on my own enough to make the game tolerable, or find a good reason why it's not possible to do so (Like when I tried to run Ratchet and Clank on 1.0.0)... so I guess this has me thrown a bit for a loop. I've got a consistently reproducible crash that comes from an action I'd been taking for 3 hours before without issue, and I can pinpoint the exact moment that this function begins to fail, but for the life of me I can't tell you *why* it's failing then and not 4 seconds before. Also, I figured it'd be easier to troubleshoot if I could provide more accurately the environment that created the crash (So that it could be recreated and possibly investigated by someone who knows what the hell to look for Laugh)

But yeah, I don't really have the hardware to do that, so I'll have to neglect that avenue of investigation and see what I can do with what I've got in terms of providing helpful or useful information here (Instead of just whining "Is broke! Halp!")
This probably has nothing to do with PCSX 2, but I figured it's related to the game and sorta interesting, so I thought I'd pipe back up for a second. I resorted to solving my emulation issue by buying the Sony sponsored emulation on the PS3 via PSN store for $10, and it came with its own barrel of fun.

So out of the gate, the depth issues are gone and apparently they added an algorhythm to smooth sprites, making the player characters look much cleaner in normal gameplay. I encountered a random crash shortly into Haschen's scenario where listening to one of Rasch's lines froze the game, but I recall that crash existing in the PS2 native game, so I didn't think much of it.

That said, I was nearly unable to clear Rockbein's scenario, because there's some weird pesistent issue that after using a Knack, the game starts *chugging* on the PS3's cpu for about 2-3 minutes, basically freezing on the resolution of the action (before damage comes up) for the whole time, before abruptly returning to normal. It seems to show up more on certain maps and in battles involving Screapers, especially Knight class, but I've seen it even in just random fights, primarily with Impede and Fierce Strike.

Also, and this might just be a corrupted graphics file as my net was acting up when I downloaded it on the PS Store, but one of Melvina's speech portraits has a graphical glitch for her mouth flap that turns about 33% of her face into a portal to Dimension X, so that's terrifying and amusing. There's also a few transparency issues, but eh.

So yeah, looks like Sony's having as much trouble as you guys have emulating their own system, except on a static platform and with their own dev notes right there, so what the hell Sony? You guys should offer to help them with PS4 conversions, since they apparently have very little grasp of their own programming @_@

Users browsing this thread: 1 Guest(s)