Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolved [Bug Report] Gsdx: Bottom part is cut off in few games
#1
Hi,

I found a little problem on some games, the screen size are wrong.
Bottom of screen are cut off on latest version of Gsdx.
Currently i found 2 games with that problem, both are in PAL:
Buffy the Vampire Slayer - Chaos Bleeds
Ct Special Forces - Fire for Effect

I guess more games are concerned by this.
It seem to be since 1.4.0 version (tested and always cut off).
The last version without problem are 1.3.0.
Checked on 1.3.0 with latest Gsdx will cause the problem too.

Ct Special forces on both version:


Attached Files Thumbnail(s)
               

Sponsored links

#2
Is the issue present in software mode? If yes, it's probably the height saturation done for NTSC videomodes but AFAIK that shouldn't affect PAL games which run in PAL videomode. Could you provide a GS dump of the issue?
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction
#3
(11-09-2017, 03:53 PM)ssakash Wrote: Is the issue present in software mode? If yes, it's probably the height saturation done for NTSC videomodes but AFAIK that shouldn't affect PAL games which run in PAL videomode. Could you provide a GS dump of the issue?

I confirm software mode having same issue.
For the Gsdump i see how to and i send.

EDIT: Gsdump done Smile


Attached Files
.xz   gsdx_20171109151018.gs.xz (Size: 1,94 MB / Downloads: 47)
#4
Yeah, it's the NTSC saturation issue and this PAL game seems to be using NTSC video mode for some reason. Why? Does this game allow selection between NTSC/PAL videomodes?

By the way, you can fix the issue on your side by setting "NTSC_Saturation = 0" in GSdx.ini file.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction
#5
(11-09-2017, 04:26 PM)ssakash Wrote: Yeah, it's the NTSC saturation issue and this PAL game seems to be using NTSC video mode for some reason. Why? Does this game allow selection between NTSC/PAL videomodes?

By the way, you can fix the issue on your side by setting "NTSC_Saturation = 0" in GSdx.ini file.

I think i found why i doesn't work, it's from my computer -> bad copy maked.
I retry to copy my disc(special force) few moment ago...and now it work well...i guess my dvd drive are a bit tired sometimes @[email protected]
Now i retry to copy my other game (buffy) for see if i have the same thing.
Anyway thanks for ur help, i have the idea to retry copy because you says star on videomode NTSC, and this game (special forces) seem only to start on 60fps instead of 50 without request :/

EDIT: Confirmed, remake iso have resolved problems, my DVDs have many scratch, maybe this is the cause of problem...
#6
Quote:EDIT: Confirmed, remake iso have resolved problems, my DVDs have many scratch, maybe this is the cause of problem...

No more problem then? I can close this issue as resolved?
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction
#7
(11-09-2017, 05:27 PM)ssakash Wrote: No more problem then? I can close this issue as resolved?

Yeah, no more problems, and sorry for don't think to remake iso before xD
#8
Thank you for your report.
This bug report has now been marked as Resolved since it has been fixed on our code base.

This thread will now be closed and moved to the resolved bug reports subforum.




Users browsing this thread: 1 Guest(s)