Resolved: [Bug Report] Knight Rider - The Game [PAL-E] Broken brake light
Hello dear PCSX2-Team,

i have found a graphical issue in the said game that appears in every hardware renderer and affects the brake light. Whether unscaled or scaled, the result is always the same. I have also tried overall-default settings everywhere in hardware mode, but also without success. I do not know if such a small issue deserves a bug report, but i think it does.

Game: Knight Rider - The Game [PAL-E] (SLES_510.11 / CRC = 989192FE) and maybe the other regions, too
First affected PCSX2-Version: Any PCSX2-Version
Last working PCSX2-Version: None yet

Left image: Software mode
Right image: Hardware mode (Vulkan comes closest to the software mode because of the blending accuracy at „High” and above)

Multi Frame GS-Dump:

I had trouble creating a GS dump on this game. The single frame GS dumps seem to be mostly graphically corrupt, so i created a short multi frame GS dump which is also kind of buggy, but not that much.

Attached Files Thumbnail(s)

Sponsored links

Okay, it seems you can solve this problem with „Auto Flush” and „Preload Frame Data” enabled together. Works with all renderers, even scaled and i cannot detect any other problems with it at this time.

Attached Files Thumbnail(s)
on a modern 1.7 nightly build with your GS Dump, just enabling Auto Flush was enough for me.

Edit: Ran the actual game, that needed preload lol

We'll get it added to the DB, thanks!
[Image: ref-sig-anim.gif]

I always use the latest version. Yes, „Auto Flush” is unfortunately not enough. But that is not bad, is it? There are certainly games that need more fixes. Anyway, thanks  for the courtesy! Laugh
Well preload is technically correct, but we have some code in there now to do it automatically if data has been uploaded to the place the new texture is being made, unfortunately it doesn't work if it's a different format Tongue
[Image: ref-sig-anim.gif]

I have faith in you guys - i am sure it will be made to fit. Wink
I think that this bug report was forgotten to mark as solved since PCSX2 v1.7.4174. Smile
Thank you for your report.
This bug report has now been marked as Resolved since it has been fixed on our code base.

This thread will now be closed and moved to the resolved bug reports subforum.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

Users browsing this thread: 1 Guest(s)