Resolved: [Bug Report] Metal Gear Solid 2: Substance (PAL) - SLES 82009
#1
PCSX2 Version - r5816
Using included version of GSDX in DX11 hardware or software, or OpenGL Software.

I've just started playing this and have encountered a small issue. When you open the codec screen the background should be a green, zoomed version of whatever was onscreen prior to opening it. This works as intended on the NTSC version of the game. On the PAL version however, one of two things happens: Either the background is black, or the background zooms in on something, but that something looks like random garbage rather than a manipulation of the previous screen.

This happens on all GSDX modes.

Sponsored links

#2
could you please post screenshots ?
is this issue present on earlier SVNs ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
#3
(01-17-2014, 12:58 AM)jesalvein Wrote: could you please post screenshots ?
is this issue present on earlier SVNs ?

Ok here goes.

Exhibit 1: The Scene in game:
[Image: 9uuw.png]

Exhibit 2: Codec screen open on the NTSC version:
[Image: 8889.png]

You'll have to trust me that the background is basically the first image scaled, blurred, darkened, and turned green. This is how it's supposed to look.

Exhibit 3: PAL Version:
[Image: bfmx.png]

Exhibit 4: What it appears to be zooming in on in PAL version:
[Image: 8pgm.png]

Sometimes the background will just appear plain black. The corruption (instead of the black, it never displays as intended) tends to appear after making a codec call and it's possible that some cutscenes trigger it too. I've tried old SVN exe's combined with old GSDX versions (r5484 is the earliest I have on my computer at the moment), but the same problem is apparent with those too.

EDIT: I've just found that if you take a picture with the in game camera, that last camera image will appear instead of the corruption.
#4
Thank you for your report.
This bug report has now been marked as Pushed and has been posted as an issue in our Github repository HERE

Issue link: https://github.com/PCSX2/pcsx2/issues/1339 (Half-screen meta)

This thread will now be moved in the Pushed bug reports subforum.
#5
Thank you for your report.
This bug report has now been marked as Resolved since it has been fixed on our code base.

This thread will now be closed and moved to the resolved bug reports subforum.
CPU: I7-4770 3.9GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ CL9
GPU: GTX750TI 2GB GDDR5
OS: Windows 10 Pro 64bit




Users browsing this thread: 1 Guest(s)