Resolved: [Bug Report] Ratchet: Gladiator (PAL) - PCSX2 r4450 - Assertion Failure error
I just beat the Reactor boss fight and got this error after the "new armor" cutscene. I can try to continue the program but it will just keep giving the same error message, and if I press yes to close it, it will crash with a generic "pcsx2.exe has stopped working" windows error message.

This is on the current latest Pcsx2 build at the time of writing. No other problems up to this point (although, the game used to also crash before the reactor fight with a TLB miss error in the last build I tested, but it seems to have gotten fixed with the newer revisions Tongue2).

Comp specs:

- Intel Core 2 Duo T6600 2.2 Ghz
- 4 GB RAM
- Ati Mobility Radeon HD 4670 XT 1 GB
- Windows 7 64 bit

Using all speedhacks except VU cycle steal on medium and no block hack or fast cd/dvd hack and the game seems to run perfectly fine otherwise with this config.

Attached Files Thumbnail(s)

Sponsored links

And what about disabling all hacks?
Well I'll give that a shot. I have a memory card save right on the spot where it crashes so I guess there's no harm in that. Tongue2

EDIT: Tried without speedhacks and got the exact same message. :/
your pcsx2 is svn ver.?
Okay, after a long break without touching pcsx2, I tested the game again in r4660 and it gets past that point without issues now, good work. Smile
Thank you for your report.
This bug report has now been marked as Resolved since it has been fixed on our code base.

This thread will now be closed and moved to the resolved bug reports subforum.

Users browsing this thread: 1 Guest(s)