Resolved: [Bug Report] Ratchet and Clank: Up Your Arsenal [NTSC-U]
#1
PCSX2 Version: Nightly v.1.7.4344
CPU Options: EE/IOP Defaults, VUs defaults
Plugins used: Software, Vulkan, Direct 3D11, Direct 3D12
Description: Character geometry is broken (depicted in the attached picture). This happens when you mess around with EE Cycle Rates, however, this is happening to me even at default settings (100%). Underclocking to 75% fixes it, but also makes the game slower. Strangely enough, starting a new game, or loading to a savestate I made some hours ago seems to fix it. Although I messed with EE Cycle Rates in this game before, I didn't mess with EE Cycle rates between this last savestate and now, so I'm not really sure what made the game behave like this. I have tried Soft and Full booting the game normally at normal velocity, and the problem still persists. This can theoretically be fixed by loading a previous save state, but I would lose a lot of progress and there is the chance of it happening again.


Attached Files Thumbnail(s)
       

Sponsored links

#2
Go in to Game Properties->Game Fixes, and tick "Full VU0 Synchronisation"
[Image: ref-sig-anim.gif]

#3
though I'd also appreciate a savestate on that screen, if you could.
[Image: ref-sig-anim.gif]

#4
(04-08-2023, 09:41 PM)refraction Wrote: though I'd also appreciate a savestate on that screen, if you could.

Sure, I'm not very knowledgeable about the process but it should just be the .p2s file right?
The file is too big and I can't post URL links so here is a .txt file containing a MEGA link, sorry if that's breaking any rules.

EDIT: Also, I'm new to using the Qt GUI so I'm not sure where exactly to find "Game Fixes", I have ticked the "Manual Hardware Rendered Fixes" option but still can't find it.

EDIT 2: Figured it out Smile


Attached Files
.txt   Mega.txt (Size: 73 bytes / Downloads: 87)
#5
(04-08-2023, 09:40 PM)refraction Wrote: Go in to Game Properties->Game Fixes, and tick "Full VU0 Synchronisation"

After some testing, the problem still persists with "Full VU0 Synchronisation" hack active, I tested with default settings, on Software; 3D11; 3D12 and Vulkan. And also while loading the game state directly, Soft booting anf Full booting. Like before, running the game at 75% EE Cycle Rate fixes the problem. This problem has persisted even after restarting my computer.
#6
I just made a PR which will fix it at the normal cycle rate, so once this gets merged in to the code (possibly tomorrow) it will be fine. https://github.com/PCSX2/pcsx2/pull/8614
[Image: ref-sig-anim.gif]

#7
(04-09-2023, 03:05 AM)refraction Wrote: I just made a PR which will fix it at the normal cycle rate, so once this gets merged in to the code (possibly tomorrow) it will be fine. https://github.com/PCSX2/pcsx2/pull/8614

Thank you so much for the help! Glad that my bug report was somewhat useful and wasn't me just messing some settings up that I shouldn't have touched Smile.
#8
We had other reports of it but could never reproduce it, but your savestate was perfect, thanks Smile
[Image: ref-sig-anim.gif]

#9
Thank you for your report.
This bug report has now been marked as Resolved since it has been fixed on our code base.
https://github.com/PCSX2/pcsx2/pull/8614

This thread will now be closed and moved to the resolved bug reports subforum.




Users browsing this thread: 1 Guest(s)