Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolved [Bug Report] [Silent Hill 2] GSdx Screenshots have wrong height.
#1
   

I should mention that this isn't a major or severe bug, but it should still be reported I guess.

I was taking some screenshots using the GSdx screenshot function (F8 while in-game). But then after checking on them, I noticed the height was wrong.

Instead of having 1920x1080, it was saved at 1920x521.
Instead of having 2560x1440, it was saved at 2560x695.

When GSdx is set to Native Res, the height is correct, but this obviously results in bad quality.


I think this might be related to an old bug with the game in previous versions of GSdx/PCSX2 where the screen would only show half of it while playing. This was fixed in later revisions, but it seems there's still a remnant of it somewhere when taking screen captures.

Back when that bug was around, it only affected NTSC versions of the game. PAL versions were fine afaik.

Tested versions:
  • PCSX2 GIT 1.3.0-639 (GSdx: 20141004113334 MSVC 18.00, AVX2)
  • PCSX2 SVN r5932 (GSdx: r5932 MSVC 16.00, SSE41)

- No Speedhacks were used
- No HW hacks were used in GSdx.
- Manual Gamefix applied: Enable SW Mode when an FMV plays (Should have no impact on this bug, but I went ahead and tested it with this fix turned off too, and the result was the same).

Right now I'm just using Bandicam to take screenshots instead, as I know of no other alternative to get around this.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)

Sponsored links

#2
Windows PrintScreen function works with PCSX2. Just press Print Screen(if in full screen) or ALT-PRINTSCREEN(if windowed mode). Then go to paint or whatever and CTRL-V it in. Of course Bandicam prolly works better for you(since with it you don't gotta drop out of the game to paste your screenshot into a program), just thought I'd mention this.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#3
Yep, Bandicam is the better alternative for me atm.

I prefer the GSdx screenshot function though, because it takes screenshots at whatever your internal res is at, even if you're not playing in Fullscreen or if your monitor doesn't actually support said resolution. Smile Not sure how complicated it is to fix this though.. I know rama was pretty involved with the old bug in SH2 if I remember right, so maybe he can shed some light on this possibly being fixed in the future.
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
#4
could you try reproducing this issue with CRC hacks disabled in HW hacks settings ?
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
#5
Just saw this post. Tried it with CRC hacks disabled, same result.

I should mention that in this latest revision (1.3.1-530) the screenshots are now saved at 2560x1260. (Still missing 180 pixels there though, and it gets 'stretched', so the entire image looks off.)
Intel Core i5-4670K @ 3.40GHz | 16GB (2x8GB) DDR3-1866 G.SKILL Sniper Series
AMD Radeon R9 280 @ 3 GB | 120GB SSD | Windows 7 Ultimate x64 (SP1)
#6
This is not an error pcsx2/GSdx internal scaling works correctly.

Try this you lose then just two or four pixels.
But I do not understand why the system cuts (Cropping) the images before they are saved.

960x720 / 4:3

1280x720 / 16:9

1440x1080 / 4:3

1920x1080 / 16:9

2880x1620 / 16:9

2880x2160 / 4:3

3840x2160 / 16:9
MB: Gigabyte GA-X79-UP4 - Intel® X79 Express Chipset
CPU: 1x Intel® Core™ i7-4820K CPU @ 3.70 GHz
WC: Swiftech H220, Watercooling Kit (Completely Modified)
RAM: 2x 8192 - 16 GB Corsair Vengeance® Pro Series CL11 PC3-17066
GFX: EVGA® Nvidia® GeForce™ GTX 780 Classified ACX - 3,000 GB GDDR5 (With Backplate)
OS - MS - Windows 7 - Professional - x64 - SP 1

#7
Here are two examples of how Biohazard 4 is scaled correctly under 4K.

Example wrong scaling @ 3840x2160 / 4K / 16:9

[Image: gsdx_20150614161809.jpg]

Example correct scaling @ 2880x2160 / 4K / 4:3

[Image: gsdx_20150614161731.jpg]
MB: Gigabyte GA-X79-UP4 - Intel® X79 Express Chipset
CPU: 1x Intel® Core™ i7-4820K CPU @ 3.70 GHz
WC: Swiftech H220, Watercooling Kit (Completely Modified)
RAM: 2x 8192 - 16 GB Corsair Vengeance® Pro Series CL11 PC3-17066
GFX: EVGA® Nvidia® GeForce™ GTX 780 Classified ACX - 3,000 GB GDDR5 (With Backplate)
OS - MS - Windows 7 - Professional - x64 - SP 1

#8
Ryudo: Is the Issue still present on the latest development build ?
#9
I'd like to direct people to this post http://forums.pcsx2.net/Thread-Removal-o...#pid470787
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#10
I checked out this issue with the PAL version and didn't manage to reproduce it. I tried a slightly newer dev build than the one in the OP from late 2014 and one of the latest 2016 dev builds , but all screenshots were saved at the height I selected in-game.




Users browsing this thread: 1 Guest(s)