Resolved: [Bug Report] Soul Nomad & the World Eaters [NTSC-U]
# PCSX2 version: SVN r5919 and version 1.3.0 (5, June, 2014)

# CPU options: EE/IOP defaults, VUs defaults

#Plugins Used: GSdx 5912 (MSVC 16.00, AVX, SSE2) 0.1.16 [GSdx32-SSE2-r5912], Lilypad svn (r5822) 0.11.0 [LilyPad-r5822], SPU2-X r5893 2.0.0 [SPU2-X-r5893], cdvdGigaherz (r5822) 0.8.0 [cdvdGigaherz-r5822], USBnull Driver r5822 0.7.0 [USBnull-r5822], FWnull Driver r5822 0.7.0 [FWnull-r5822], Dev9null Driver r5822 0.5.0 [Dev9null-r5822]

# Description: During the tutorial battle, once I select the main character, I'm unable to do anything that shows a response but press R2 (Zooms out/In) and use the right stick (changes view of the area). I'm pretty sure it isn't a hardware issue, as I can play normally up to that point and use all the buttons, as well as the fact that I can play other Nippon Ichi games just fine, but if it matters, the controller I'm using is a Gamestop Xbox 360 wired controller. I do have reason to believe that it isn't a hardware issue, however, as I've attempted controlling the menu with my arrow keys after altering my control scheme on Lilypad. Still unsuccessful.

Here is a screenshot of the point where I can no longer control the game. I can't move the cursor down the menu. I also replayed up to that point and tried the settings menu, but to no avail. However, I can manipulate the cursor on the settings menu in the start screen perfectly fine. I'm unsure of how to describe how to replicate the bug without someone else testing the game, so I described the conditions used as best I could. I'm sorry I couldn't do anything more. I tried this with standard speedhacks and then reloaded the game with no speedhacks. Still nothing.

Thank you for any help you can give, I truly appreciate anything to help. If any more information is required, I'll be happy to provide it.

Sponsored links

It could be your pad configuration. Have you configured the left analogue sticks? Have you tried the dpad keys and the left analogue stick to control the game?
Mhm, I've tried both. At this point I'm ruling out there being an issue on the gamepad, because as I said, I can navigate menus up to that point. To make sure nothing was up, I dug up my copy of Makai Kingdom and backed it up. It's a similar game in many regards, made by the same publishers and with the same menu system, and it works perfectly. It's just Soul Nomad that shows the issue.
I'd get to the same conclusion as well but I happen to know this problem often comes up and confused people Tongue2
Try mapping a keyboard key to DPAD down and also left stick y axis and see if it works then.
If not, it could be a recompiler bug. Try changing the EE round and clamp modes to see if they make a difference.
Changing the EE round and clamp modes does nothing, and neither does trying it with the down arrow key. I'm not sure if this is an isolated issue on my part or if it was an issue brought upon by the SVNs somehow, but I think someone else would need to test it to see if it works, to be honest.
Have you tried a different input plugin?
[Image: XTe1j6J.png]
Gaming Rig: Intel i7 6700k @ 4.8Ghz | GTX 1070 TI | 32GB RAM | 960GB(480GB+480GB RAID0) SSD | 2x 1TB HDD
Oh, a different input plugin seems to solve it. I had tried different Lilypad plugins assuming that would do the same, but changing it to SSSPSX PAD Pressure Mod 1.7.1 [PadSSSPSX] worked perfectly. Thank you for the help, Blyss. I truly thought just changing Lilypads would be fine, but it clearly wasn't.
That happens every now and again, where a game and Lilypad doesn't get along. Dunno why, never happened to me, but I've seen it happen to others.

Anyway, glad you got it sorted.
[Image: XTe1j6J.png]
Gaming Rig: Intel i7 6700k @ 4.8Ghz | GTX 1070 TI | 32GB RAM | 960GB(480GB+480GB RAID0) SSD | 2x 1TB HDD
Thank you for your report.
This bug report has now been marked as Resolved since it has been fixed on our code base.

This thread will now be closed and moved to the resolved bug reports subforum.

Users browsing this thread: 1 Guest(s)