Resolved: [Bug Report] Syphon Filter: The Omega Strain [NTSC-U] (Solved)
# PCSX2 Version: Official v1.0.0 Release / SVN Release
# Emulation Options: All defaults (also tried EE/IOP Clamping to Full and VUs to Extra + Preserve Sign)
# Plugins Used: GSdx 5723 (in D3D9, D3D11 and OpenGL, and in Hardware and Software mode for all), ZeroGS
# Description: This is a simple bug, yet a pretty game breaking one. Basically the flashlight used in the game does not work (it does not light up anything).
Since many stages have pitch black areas that require the use of such item, it makes it simply impossible to progress through the game.
I have attached images of both the flashlight on and off: as you can see, there is no diference at all. I have also attached images of the same situation, but with higher gamma (in-game option). However, this cannot be used as a work-around, since most dark areas are not affected by the gamma, and therefore, again, remain pitch black.
Any help would be much apreciated. If I have not mentioned any necessary information, I will do so as quickly as possible.

Attached Files Thumbnail(s)

Sponsored links

After some further investigation, I realized the problem is much bigger then simply the flash light not lighting anything up. Apperently, it is a much more generalized lighting problem.
First of all, there is the problem with the flashlight, which doesn't light anything at all. Second, there are areas in the game that are completely pitch black (as I mentioned before). However, I thought those areas were like this because they needed the in-game flashlight to light them up, which would make sense. However, I realized the areas themselves are bugging.
Basically, there is a second lighting mechanism in the game, which is the night vision goggles. As you would imagine, they should "light up" every area in the game, making them a work-around to the flash light. However, they do not "light up" these pitch black areas, which is what should be happening if the game was to be working correctly.
Furthermore, I tried using "Shader boost" option in the graphics plugin for brightness, and, although that affected most areas in the game, the totally dark ones remained the same.
Are there any similar lighting glitches in other games that could be used to have na idea as of what is going on? Again, I would kindly ask for any help, since I have had no response for many days now. If I need to post any other necessary information, I will do so as quickly as possible. Thanks.
Try software mode then.
Core i3 9100f 3.6Ghz
nvidia GT 1030
pcsx2 version-1.3.1  
(08-27-2013, 08:44 PM)Brock lessner Wrote: Try software mode then.

read before replying, please.
Quote:# Plugins Used: GSdx 5723 (in D3D9, D3D11 and OpenGL, and in Hardware and Software mode for all)
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
(08-27-2013, 08:47 PM)jesalvein Wrote: read before replying, please.

sorry jesalvein, actually i watching tv and thats why i am not read this carefully :-P (how stupid i m)
@op- sorry brother for that.
Core i3 9100f 3.6Ghz
nvidia GT 1030
pcsx2 version-1.3.1  
I have now tested out many old and new PCSX2 versions (back from archieve files to older SVN builds) and all versions seem to have the same problem. So no versions made up until today do not have the issue, it seems. Again, I would ask for any help possible. Other threads seem to have almost instant replies and I have had no decent one up until now. If there is ANYTHING I can do or look into I will do so gladly. Thank you.
Not working in software mode either means an emulation bug of some sort. First I'd try (one at a time) the special game fixes to see if any of those fixes it. You can also try changing clamping in the GS/VU settings to "extra + preserve sign" though I doubt that will have a tangible effect in this case.
[Image: 2748844.png]
First of all, thank you for the first helpful reply Biggrin! Ok, so I had already tried the "Extra + Preserve Sign" option, but nothing changes. I have now tried all Game Fixes but nothing seems to affect it as well. Any other suggestions? Thanks!
Allso having this problem with this game.. makes it completely unplayable later in the 1st level in the subway.. If anybody has a way to fix this please let me know thanks.
This would have to be fixed in a later SVN version, it seems. I remember playing this game on my 2nd-gen partial-BC PS3 -- the flashlight worked, but not the way it was supposed to... the flashlight was instead tilted at a weird angle, lighting up the sky (i.e. nothing useful) rather than what was immediately in front of you.

Users browsing this thread: 1 Guest(s)