Resolved: [Bug Report] Tom & Jerry's War of the Wiskers [PAL]
# PCSX2 version: Emulog was taken with a self-compiled debug version (updated to 10 april) but problem happens with every version of course
# CPU options: EE/IOP defaults, VUs defaults (also tested EE/IOP clamping to Full and VUs clamping to Extra+Preserve sign). Tested safest preset too
# Plugins used: Every plugin in its debug version. (see above). Inter alia cddvdGigaherz 0.8.0
# Description: The game doesn't start from the original CD. You just receive a black screen with the cd player that continues to seek and seek the disk in a loop.
ISO loads fine, but imo, CD should also work Unsure

Attached Files
.7z   emuLog.7z (Size: 11,49 KB / Downloads: 390)

Sponsored links

So, heck the bug report template

Short story: cddvdGigaherz seems bugged.
It properly reads game .iso, but it loops whenever I directly run the game from the original CD

CdRead: Reading Sector 16(1 Blocks of Size 2340) at Speed=24x
CdRead: Reading Sector 48(1 Blocks of Size 2340) at Speed=24x
CdRead: Reading Sector 32(1 Blocks of Size 2340) at Speed=24x

this is spammed everywhere and pcsx2 never succeed to load the 7KB SIO2MAN.IRX

Thanks for any help Happy
Could the disk be scratched?
(05-13-2014, 10:41 PM)willkuer Wrote: Could the disk be scratched?
I don't think so. I easily copied the cd files on the main hard disk and compared the checksums. They were the same

And I had speeds ranging from 900 to 1500KB/s while copying data.. but newer less, nor any pausing

What instead intrigues me is that the emulog claims to be reading the CD with Speed=24x

Which is about 2 times the actual CD speed
Could this be related?
24x is the maximum CD read speed of the drive. The game simply requests maximum and PCSX2 delivers Tongue2
Have you tried a different CD plugin?

Edit: It appears there's a bug in giga's cdvd plugin. We're on it Tongue2
Should be fixed in the latest git build of cdvdgigaherz Smile
Nice! Thank you
We'll report back as soon as somebody will be so kind to compile the new git d:

By the way, are there any other cd plugin out there? your previous post implied this

****ThisSector variable had a pretty bad-ass name though Tongue
Yeah, there should be others but afaik giga's is best for actual disks.
New build is up, please test and report if it works for you Smile
it still gives the same error output, on the same sectors Sad

Users browsing this thread: 1 Guest(s)