Resolved: [Bug Report] Totally Spies: Totally Party [PAL]
Old bug report thread:

# PCSX2 version: PCSX2 1.5.0-20160509094534 - compiled on May  9 2016

# CPU options: Tested all EE and VU rounding/clamp modes and Interpreter mode

# Plugins used: GSdx 2016050994534 - AVX2 (Hardware and Software, DX11 and OGL), SPU2-X 2016050994534 2.0.0

# Description: Ingame 3D graphics are completely broken.

# Additional Notes: I have tested this game on my PS3 and it has the exact same problem.
Whenever there is 3D on the screen the game spams the log with:
microVU0 Warning: startPC = 0x2800, cycles = 0x2000
So much that after like 5 minutes of testing it was over 2 MB.

HW or SW mode made no difference. Weird is that the problem is still there even in Interpreter modes. Either some core problem or the game does weird stuff.
Also in EE Interpreter mode an additional: "Cache mode e not impemented" spams in the console/emuLog. I also tried to enable EE cache and it had no effect.

Attached emuLog after getting to 3D part and staying there for a couple of seconds.

Attached Files
.rar   emuLog.rar (Size: 4,05 KB / Downloads: 257)

Sponsored links

Why didn't you update the old thread instead? I've closed the old one, so sense in having duplicates active.

Have you tried the XGKick game fix?
i didn't want to necro that because it was old from 2011/2014
will try and report back in a sec

Quick Edit: Tried it and it is still the same.
Hmm, that game is trying to start outside of the VU memory, presumably using the mirrors, it should be compensating for that (the code says it is just after that warning). Does it actually show any 3D or does it just go exceptionally slow?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
it shows 3D but it's broken it looks like triangles fly all over the place.
see attached pic.

Attached Files Thumbnail(s)
Hmm not sure what's going on there, it should be handling the thing it was spamming, maybe something else is going on, how annoying ;p
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
a long time ago when i initially made the bug report in 2011 or so i remember trying all sorts of stuff to try and get tthis to at least do something different but aside from just killing the 3D part completely i did not get very far XD.
maybe the "Cache mode e not impemented" has something to do with it, and it has something to do with EE emulation? dunno just grasping straws here.

I still find it very weird that it happens with the interpreters too even if they are the most accurate (albeit slow).
Remaining VU issues have been fixed, additonal SPS requires +3 EE cyclerate

Thank you for your report.
This bug report has now been marked as Resolved since it has been fixed on our code base.

This thread will now be closed and moved to the resolved bug reports subforum.

Users browsing this thread: 1 Guest(s)