Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolved [Bug Report] Unicode Pathname Breaks Snaps (F8) Function Regardless of Plugins Used
#1
Hello, I am a new user of PCSX2 and I would first like to thank the members of the PCSX2 team for the great work they've done.

This technically is not an "emulation" bug. But changing plugins did not fix it, which is why I've posted this in the PCSX2 bug reports section.

#PCSX2 versions tested: 0.9.8, 0.9.7
#CPU options: EErec on, VUrec0 and VUrec1 on, MTGS on
#Plugins Used: GSdx 0.1.12/0.1.13/0.1.14/0.1.16 (DX9 hardware/software, DX10 hardware/software); ZeroGS 0.97.1 (DX9 hw/sw, DX10 hw/sw); LilyPad 0.10.0; SSSPSX PAD Pressure Mod 1.7.1
#Description of the bug and of how to replicate it: Install PCSX2 into a directory that has unicode in the pathname----snap function (F8) will not work.

I apologize beforehand if this turns out to actually be a plugin issue (meaning I would have posted this bug report in the wrong section). However, given the circumstances as I explain below, I am unable to determine whether it is a bug with PCSX2's handling of directory pathnames, or whether it is a bug with both the GSdx and ZeroGS plugins.


Issue: PCSX2 does not seem able to properly handle directory structures with unicode characters in the pathname for the snap (F8) function.


Short Summary of My Findings:
  • I installed PCSX2 0.9.8 in a directory that has unicode characters in the pathname (Unicode characters in red: "W:\Extra\ゲーム\PCSX2-0.9.8-r4600-binaries")
  • All my games that I tried loading into it worked fine; I am not using and speedhack settings or any hacks at all
  • However, the snap function (F8 key) refused to save any snapshots to the "snaps" folder
  • I tried using: GSdx, ZeroGS, and PCSX2 0.9.7
  • I also tried using SSSPSX PAD Pressure Mod instead of LilyPad (0.10.0), and tried changing the keyboard API settings in LilyPad
  • Changing plugins did not solve my issue
  • What fixed the issue: I copy pasted my entire PCSX2 0.9.8 directory to another location with no unicode characters in the pathname ("E:\PCSX2-0.9.8-r4600-binaries"), and the snap function (F8) finally started saving *.bmp files in the "snaps" directory
  • Thus, I am led to believe that PSCX2 is not handling unicode pathnames properly only for its snap function, and that it is not a plugin issue. Unless both GSdx and ZeroGS do not have proper unicode support

The Full Process I Went Through (long version of the list above):

Today, I downloaded "pcsx2-0.9.8-r4600-binaries.7z" and extracted it so that PCSX2's location looked like:

Code:
W:\Extra\ゲーム\PCSX2-0.9.8-r4600-binaries

I am not using any speedhacks and do not have any GSdx hacks enabled.

I got everything working and running smoothly after reading the elaborate official configuration guide posted on the forums. So it seems that most of PCSX2 supports unicode path directory handling.

Then, I decided I wanted to take snapshots of my games. However, no matter what settings I used in the GSdx plugin (DX9, DX10, hardware, software, etc), I could not get the snaps function to work.

Next, I downloaded PCSX2 0.9.7 (older version) and nabbed ZeroGS 0.97.1 from that and loaded it into my PCSX2 0.9.8, and selected that plugin, but snap would not work with ZeroGS either no matter what setting I used. At the same time, I tried the snap function in PCSX2 0.9.7 (same directory with unicode in the pathname), and it didn't work.

I searched on the internet, and found posts saying the folder for snapshots needs to be named "snaps" OR "snap", but having folders with these names in the PCSX2 0.9.8 directory did nothing.

I next found super old posts from 2009 saying that older versions of LilyPad were making the snaps function key break. So I tried SSSPSX PAD Pressure Mod instead of LilyPad, which didn't change anything. Furthermore, I tried loading LilyPad again and cycling through all the keyboard API settings, but this didn't fix the snaps issue either.

Finally, I thought that maybe the unicode pathname is messing it up. So I copy-pasted my entire PCSX2 directory to another location so that the pathname would not have any unicode characters:

Code:
E:\PCSX2-0.9.8-r4600-binaries

This fixed the problem.

-----------------

I understand this is probably...really super low priority for the developers (if it really is a PCSX2 bug and not a bug with both GSdx and ZeroGS). But it would be nice if PCSX2 were fully unicode compatible.

Sponsored links

#2
is this a bug report? Tongue2
hmm. the only possible reasons that i think might be that the snap function does not uses the UNICODE Charcaters.Ask the developers for the unicode support Laugh
kagamism Wrote:I searched on the internet, and found posts saying the folder for snapshots needs to be named "snaps" OR "snap", but having folders with these names in the PCSX2 0.9.8 directory did nothing.

Well, its not nessecary to have the folders named Snaps or snap.
#3
libpng if it is used has issues with unicode characters and has required hacks to get it working properly for as long as i've known it.
#4
The problem you're experiencing is likely a limitation of the current plugin API. Try changing your windows locale if you want support for paths using characters from other languages in plugins.
#5
Thank you for your report.
This bug report has now been marked as Resolved since it has been fixed on our code base.

This thread will now be closed and moved to the resolved bug reports subforum.
[Image: 36a66c559937a1f5d0cd7460362d4093.jpg?bg=2c2c2c]




Users browsing this thread: 1 Guest(s)