Resolved: [Bug in Linux Beta UI] Plugin Configuration mislink in UI
disclaimer: this is not a bug in the emulation code its about a (sadly essential) bug in the linux beta's user interface, its essential 'cause it keeps me from being able to test the beta on ubuntu 9.10 at all :/

when i click the configuration button of the graphics plugin selection (not in the plugin, in the main config window), it opens the Ethernet/Harddisk plugin's configuration window instead, so i suppose the bug is a wrong link (whether by number or id) in the function, probably a misclick while using the IDE, should be easy to fix it..

hope i dont draw too much attention away from more important topics like seg faults or other emulation code stuff, but i just thought you should know Wink

thankful for any replies
and big thx for coding PCSX2 (having the windows beta working in a splendid fashion)


gl hf Smile

Sponsored links

What revision number of pcsx2 you are mentioned?
its the public beta build (the one downloadable under public beta on the main page), from the installer file name i guess its 1736, sry cant check on the OS right now since i am on the windows comp, hopefullky thats enough info for you
I'm quite sure it works, although 1736 is a little dated. There's an 1888 beta also for download here at (the googlecode site and are out of sync because they're updated by two different people usually).

The GSNull plugin's window title says "FWnull" -- which could be a bit confusing if you have that one selected for some reason.
Jake Stine (Air) - Programmer - PCSX2 Dev Team
thx for your input Air, but what i dont get is, why do you give me the link to the main dl page? o_O (since its exactly that LINUX beta version i have the issue with (1736)) the 1888 beta on the main pub dl page is the WIN version (thats the one that works fine, but obviously not for linux Wink

and im quite sure im not confused by the windows caption, since the only options i get are 2 checkboxes for ethernet/harddisk when i click on the gfx config button, so i still guess its a mislink (the event handler probably referrs either to wrong component or the function is a little bit messed up)

anyways thx for the input even if it didnt hit the nail Wink
Not exactly like Cyronc's problem but ...

Today 14-11-2009 with the revision 21..

SO: GNU/Linux Ubuntu 9.10

Computer specs:
AMD cpu 710 (phenom II 2600mh with 3)
ATI Radeon HD4670
MB: Gigabite M720-US3

Screenshots in time:





Screenshot 3


Those screenshots are a little too small to be read.
Jake Stine (Air) - Programmer - PCSX2 Dev Team
(11-15-2009, 01:17 AM)Air Wrote: Those screenshots are a little too small to be read.

Blink Blink

Only needs to click on them to view at fullsize

I tried and posted before you edited them to work, judging by timestamps.
Jake Stine (Air) - Programmer - PCSX2 Dev Team
I couldn't reproduce it in windows, which is odd because that wizard shouldn't have any platform dependent code in it. Either that or I fixed it in a newer revision.

In any case it's not a bug. Just hit cancel and ignore it for now. That specific warning is not supposed to happen, but it's not really a big deal if it does.
Jake Stine (Air) - Programmer - PCSX2 Dev Team

Users browsing this thread: 1 Guest(s)