Resolved: [Bug report] The Suffering [NTSC]
# PCSX2 version: -r528, -r478 & 0.9.4
# Playground version: official playground release 1.0.0395
# Cpu eerec on, vurec0 and vurec1 on, MTGS on
# Plugins used: Gsdx 0.1.14 or ZeroGS 0.97.0/0.97.1, spu2ghz 1.9.0 or ZeroSPU 0.4.6

# Description: Game will stop after "Midway" intro CG animation. CG animation runs correctly. The game stops at the end of the CG intro and image on screen is frozen. The end part of the sound of the CG loops. You don't make it into the menus. This is the case for -r528 and -r478.

Under 0.9.4, "Midway" intro CG bad stepping effect. You DO get into the menu (same bad stepping effect) and from there into the game. The game looks like it's having a bad zorder problem. Game elements start showing up before the menu screen finishes loading.

The effect is the same no matter what plugin is used. Game unplayable.
Phenom II 965 oc 3.9Ghz, ATI 5870, 4 Gigs RAM, Win7-64

Sponsored links

Pcsx2 snapshot 612 appears to have fix the problem of getting into the game's menu. Looks real good until the game almost finishes loading, then the same problems listed above exists.

Update: There are two different "Midway" intros before going into the menu. If it looks like a grey school locker, the game will stop and not get into the menu. If it's the other intro, you'll get to the menu and then into the game.

Here are some screen shots to show the odd behavior of the game.
Phenom II 965 oc 3.9Ghz, ATI 5870, 4 Gigs RAM, Win7-64
Game responds the same under Pcsx2 0.9.6 with the same plugins. Same graphical problems exist. See above screen shots.

NOTE: No change under beta 720.
Phenom II 965 oc 3.9Ghz, ATI 5870, 4 Gigs RAM, Win7-64
Hello, do you know if there is a way to fix this game?

I have the same problem with The Suffering 1 & 2, i tried a lot of version, even the last one : PCSX2 SVN r5125 ,and still the same problem as GameCodingNinja.

Thanks in advance.
Depth issues in the 1st game are no longer present in latest builds.

Thank you for your report.
This bug report has now been marked as Resolved since it has been fixed on our code base.

This thread will now be closed and moved to the resolved bug reports subforum.

Users browsing this thread: 1 Guest(s)