Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolved: Latest Dev Builds not loading... on WinXP-Pro
#31
Did anyone who is experiencing the problem tried the GSDX version of those revs?
v1.2.1-256-g3daff15 - works fine
v1.2.1-257-gd3ebdae - the problem exist

Sponsored links

#32
Here is a new pcsx2.exe which supports this solution of the problem based on the latest build 646-ga28d287.

I've installed Visual Studio 2013. It seems not to interfere with Visual Studio 2012.
#33
The fix works on Windows XP Hurray ^_^ .
so I will upgrade my main install to the new build

I just grabbed a copy of the latest auto build mentioned r646....
and the fix version of r646.... so tada's fix has not not been permanently committed to git yet? hence the need for a custom build of r646?


ps:

I noticed some new visual artifact not released to this fix in the intro video of FF12.... in some of the black areas of some of the Arcadian Ships the was weird patterns

I haven't played it in a few months.... so the current build I uses is r545 for a long time....
r545 showed them too.. only differences are two things

1) moving from a [Nvidia GTS 250 512MB] to a [Nvidia GTX 750Ti SC 2GB] and the updating of Nvidia Drivers
I was 321.xx a while back and having been using 344.11 and moved to 344.48 yesterday all other programs I use seem to bee working normally ;;^_^;; which is great news for that Nvidia Driver release.
(PC Specs)
CPU: AMD FX-9590 4.7GHz 8-core
CPU Instructions: MMX(+), SSE, SSE2, SSE3, SSSE3, SSE4.1, SSE4.2, SSE4A, x86-64, AMD-V, AES, AVX, XOP, FMA3, FMA4
Motherboard: Asus SABERTOOTH 990FX R2.0
GPU: nVidia GTX 1070 Ti 8GB
GFX Drivers: Nvidia v431.60
OS: Windows 7 Ultimate 64-bit SP1
RAM: 32GB Kingston 1866MHz DDR3
#34
Yeah it hasn't been pushed yet. So either use my build or the one tadatada posted. My build was the latest GIT, and I went in and manually did tada's changes. It's a full package, including all plugins and GSdx versions.

Tadatada's is just the PCSX2.exe itself with his changes, so it can simply be dropped into an existing build from the buildbot.

Either way, people with this issue do one of those things for now.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#35
I need to dig out a cause of this problem to find out more effective solutions. It will take some time until I propose it.
#36
Ehr sorry if I missed some of the development here, but is a fix found for this?
If it's simple, can you open a PR for it?
Thanks Tongue2
#37
(10-27-2014, 07:52 PM)rama Wrote: Ehr sorry if I missed some of the development here, but is a fix found for this?
If it's simple, can you open a PR for it?
Thanks Tongue2

tadatada determined it was indeed the commit I PM'd you about. It somehow causes an infinite loop with certain theme settings/resolutions. He made a fix which is tested to work, but apparently he thinks it's more of a hack than a fix, and wants to work on a more proper fix.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#38
(10-25-2014, 09:38 PM)Blyss Sarania Wrote: Here it is. I tested it with classic on Windows 7 and the hang is gone. This is the latest GIT source, + tadatada's fix:

PCSX2 1.3.0 (25, October, 2014 + tadatada fix)

Please anyone who tests it report back!

tested, no hang Smile wooo!
#39
(10-27-2014, 12:56 PM)tadatada Wrote: I need to dig out a cause of this problem to find out more effective solutions. It will take some time until I propose it.

I tied r646 + Tada's custom exe last night ^_^ works great and I don't see those visual artifacts... weird... Blink.


The last Build I had grabbed from the build bot was r545... so some where after that it broke...
http://buildbot.orphis.net/pcsx2/
(PC Specs)
CPU: AMD FX-9590 4.7GHz 8-core
CPU Instructions: MMX(+), SSE, SSE2, SSE3, SSSE3, SSE4.1, SSE4.2, SSE4A, x86-64, AMD-V, AES, AVX, XOP, FMA3, FMA4
Motherboard: Asus SABERTOOTH 990FX R2.0
GPU: nVidia GTX 1070 Ti 8GB
GFX Drivers: Nvidia v431.60
OS: Windows 7 Ultimate 64-bit SP1
RAM: 32GB Kingston 1866MHz DDR3
#40
I've pushed a new commit.

Fix resizing loop when the Windows Classic theme with some large resolutions have been chosen. #335
https://github.com/PCSX2/pcsx2/pull/335




Users browsing this thread: 1 Guest(s)