Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolved: Latest Dev Builds not loading... on WinXP-Pro
#51
Can you compile the SSE2 of GSDX with that change removed to try it.

Sponsored links

#52
Yeah, hold on.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#53
Here, the latest GSdx with that commit reverted:

https://www.dropbox.com/s/mv2x8ogd0m29jd...ub.7z?dl=0
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#54
Well believe it or not,pcsx2 works fine now with this GSDX while using DX9HW
Moved the dll to the latest pcsx2 beta plugins directory after extracting it,select it with pcsx2 and run the game
#55
So that commit somehow messed up GSdx for you. Hmm. I wonder why.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
#56
Edit:

To ask this matter to lioncash who committed this change would be one of solutions.
https://github.com/PCSX2/pcsx2/blob/mast...ureFX9.cpp

At least calling order seems to be simple. The followings are just the calling order what I found, and the specification of the SetSamplerState method. This is what I can do about this matter.


GSDX: Replace an FLT_MAX with the appropriate ULONG_MAX
https://github.com/PCSX2/pcsx2/commit/63...2710f792f0


https://github.com/PCSX2/pcsx2/blob/mast...9.cpp#L223
Code:
GSTextureFX9.cpp:

0223:             ss->MaxLOD = ULONG_MAX;


https://github.com/PCSX2/pcsx2/blob/mast...9.cpp#L881
Code:
GSDevice9.cpp:
StretchRect -> PSSetSamplerState

0832: void GSDevice9::StretchRect(GSTexture* st, const GSVector4& sr, GSTexture* dt, const GSVector4& dr, IDirect3DPixelShader9* ps, const float* ps_cb, int ps_cb_len, Direct3DBlendState9* bs, bool linear)
0833: {

0881:     PSSetSamplerState(linear ? &m_convert.ln : &m_convert.pt);


https://github.com/PCSX2/pcsx2/blob/mast...1294-L1330
Code:
GSDevice9.cpp:
PSSetSamplerState -> SetSamplerState

1281: void GSDevice9::PSSetSamplerState(Direct3DSamplerState9* ss)
1282: {

1294:         m_dev->SetSamplerState(0, D3DSAMP_MAXMIPLEVEL, ss->MaxLOD);

1303:         m_dev->SetSamplerState(1, D3DSAMP_MAXMIPLEVEL, ss->MaxLOD);

1312:         m_dev->SetSamplerState(2, D3DSAMP_MAXMIPLEVEL, ss->MaxLOD);

1321:         m_dev->SetSamplerState(3, D3DSAMP_MAXMIPLEVEL, ss->MaxLOD);

1330:         m_dev->SetSamplerState(4, D3DSAMP_MAXMIPLEVEL, ss->MaxLOD);


Code:
d3d9.h: (DirectX SDK)
SetSamplerState

0500:     STDMETHOD(SetSamplerState)(THIS_ DWORD Sampler,D3DSAMPLERSTATETYPE Type,DWORD Value) PURE;



IDirect3DDevice9:WackoetSamplerState method
http://msdn.microsoft.com/en-us/library/...s.85).aspx


D3DSAMPLERSTATETYPE enumeration
http://msdn.microsoft.com/en-us/library/...s.85).aspx

Quote:D3DSAMP_MAXMIPLEVEL
level-of-detail index of largest map to use. Values range from 0 to (n - 1) where 0 is the largest. The default value is zero.
#57
@Vsub

Is this problem resolved on your XP build for the latest GSdx versions ?
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction
#58
Umm,my last post date in the thread is 3 days before I switch to Win7 because I got a new PC.

I connected my really old hdd which have nothing updated since 2011 on it(the hdd stayed unplugged since then because I got larger hdd...I plugged the 600gb hdd(which I used on my old pc since 2011 to 1.11.2014)on my new pc)so I don't know how useful the info will be if I try it(drivers,service pack,updates...everything is too old)
#59
r1051 latest build works on XP Pro x64
only issue is the savestates were outdated so they would not load, good thing I ingame save regularly
(PC Specs)
CPU: AMD FX-9590 4.7GHz 8-core
CPU Instructions: MMX(+), SSE, SSE2, SSE3, SSSE3, SSE4.1, SSE4.2, SSE4A, x86-64, AMD-V, AES, AVX, XOP, FMA3, FMA4
Motherboard: Asus SABERTOOTH 990FX R2.0
GPU: nVidia GTX 1070 Ti 8GB
GFX Drivers: Nvidia v430.39
OS: Windows 7 Ultimate 64-bit SP1
RAM: 32GB Kingston 1866MHz DDR3
#60
Thank you for your report.
This bug report has now been marked as Resolved since it has been fixed on our code base.

This thread will now be closed and moved to the resolved bug reports subforum.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction




Users browsing this thread: 1 Guest(s)