Resolved: Treasure planet [pal] bug
Treasure planet starts to the menus, but if you try to continue from the first menu the game freezes. I got this fixed by turning on EE timing hack.

When entered the game the character started moving by itself if I tried to move it. It started to hop quickly from place to another. I got this fixed by changing the fpu round mode to nearest. Also sometimes everything disappears like the character just flies away or falls down and you will only see the background of the map. This happens randomly when kicking or punching a barrel or killing a monster.

With the fpu round mode nearest the game is playable but the character flying away problem still persists though it doesn't happen so often anymore. I tried other fpu round modes and found out that with positive mode the character doesn't randomly fly away, but many ground or wall textures become transparent and you can see the same background through them as you see once the character flying bug happens.

I hope someone can find a solution for this character flying/falling issue.
Otherwise the game is kind of playable. At least I'v been able to play the first and the second map, but with some transparent ground and walls.
I'm new to this ps2 emulating and I'm not very good with the terms and just tried many things to fix it somehow. I also hope this information helps some guys and I also hope you can help me with this one last bug which i wasn't able to fix properly. I'm also sorry if I have some grammar mistakes since English isn't my native language.

My program log after starting Pcsx2:

PCSX2 0.9.8.r4600 - compiled on Apr 27 2011
Savestate version: 0x9a010000

Host Machine Init:
Operating System = Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit
Physical RAM = 6135 MB
CPU name = Intel® Core™ i7 CPU 930 @ 2.80GHz
Vendor/Model = GenuineIntel (stepping 05)
CPU speed = 2.805 ghz (8 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 0098e3bd
x86EFlags = 28100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2

Loading language translation databases for 'Finnish' [fi_FI]
pcsx2_Main not found -- translation dictionary may be incomplete.
pcsx2_Iconized not found -- translation dictionary may be incomplete.
pcsx2_Tertiary not found -- translation dictionary may be incomplete.
SetLanguage: Requested translation is not implemented yet.
Reserving memory for recompilers...

Loading plugins...
Binding GS : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\gsdx-sse4-r4600.dll
Windows 6.1.7601 (Service Pack 1 1.0)
ATI Radeon HD 5800 Series (
Binding PAD : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\lilypad-r4600.dll
Binding SPU2 : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\spu2-x-r4600.dll
Binding CDVD : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\cdvdGigaherz.dll
Binding USB : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\USBnull.dll
Binding FW : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\FWnull.dll
Binding DEV9 : C:\Program Files (x86)\PCSX2 0.9.8\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 8934 games on record (loaded in 212ms)

Sponsored links

wow a nicely described problem.
Did you try to play with the VU round modes as well? If not then give it a try, it might fix your problem.
Id put the Clamps on full before playing with the round modes, that generally sorts a lot of issues out
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Thank you for replies Smile
I have found out that punching in the air or kicking launches this flying away bug randomly sometimes it takes 10 punches sometimes 40 and so on. I tried VU round modes and they had no effect to the flying away issue.
Now i know that with FPU round modes chop/zero and negative the flying around bug happens all the time. At FPU nearest mode it happens randomly like i said above. At FPU positive mode the flying bug doesn't happen, but most of the walls and some of the ground goes transparent but playable.
I still have to try those clamps, but for now i stick with the FPU mode positive and get used to those transparent walls if i want to play.
Game requires several fixes (EE timing hack enabled, EE Round Mode set to Nearest and EE Clamping Mode set to Extra + Preserve Sign), all of which have been added to GameIndex.dbf.

Thank you for your report.
This bug report has now been marked as Resolved since it has been fixed on our code base.

This thread will now be closed and moved to the resolved bug reports subforum.

Users browsing this thread: 1 Guest(s)