Resolved-Workaround: Ace Combat 5 (NTSC), Lit Fuse Mission Unwinnable
Game: Ace Combat 5 - The Unsung War (NTSC)

Emulator version tested with: Latest SVN build (f3bb434)

Emulator Config Options:

EmotionEngine - Recompiler
IOP - Recompiler
Round Mode - Chop/Zero
Clamping Mode - Normal
Preset - 2

VU0 - microVU recompiler
VU1 - microVU recompiler
Round Mode - Chop/Zero
Clamping Mode - Normal
Preset - 2

Plugins used:

Video (GS) - GSdx 5334 (MSVC 1600, AVX) 0.1.16 (DirectX11 Hardware only, software makes the game too slow to play as does both versions of DX9, at least on my system anyway.)
Audio (SPU2) - SPU2-X r5324 2.0.0
Controllers (PAD) - LilyPad svn (r5282) 0.11.0

I am using the AC5Z Plane Patcher to eliminate invincible targets.

Descroption of Problem:
In Ace Combat 5 (NTSC), mission #9 "Lit Fuse" doesn't allow the Osean troops to advance. Specifically, the bunkers don't respawn as they're supposed to. I know how the mission is supposed to go because I had mastered the game on my PS2 before my PS2 died. This makes the mission unwinnable because these bunker respawns must occur for the mission to advance. I have tried this mission six times, each with the same result. It makes no difference if I reboot my machine or disable the AC5Z Plane Patcher.

Possibly relevant system specs:

CPU: AMD FX-8350 non-OC (4GHz)
RAM: 16GB DDR3-1333MHz
GPU: 2 X Gigabyte Radeon HD 7970 3GB (CrossfireX enabled)
Controller Pad Used: Logitech Wireless Gamepad F710 (DX)

This is my first post and I hope I have done it correctly with all the information that you require. Please note that there was a thread posted about this in 2013 in which rama said that the emulation problem was fixed at its source. Unfortunately, I have found no other references to this problem and it is a problem that is present in the current build.

Sponsored links

Try fiddling with EE & VU Round/Clamping settings. You might have to set it to Nearest and Extra for both EE and VU.

A similar thing happens in Phantasy Star Universe where the boss refuses to get out of its invisibility cloak getting you stuck forever.

Make sure you restart PCSX2 and load via Memory Card Save after changing the settings. Savestates will load your old settings.
AMD Ryzen 5 3600 @ 3.60~4.20 GHz | Corsair Vengeance LPX 32 GB (2x16GB) DDR4-3200
MSI GeForce GTX 1660 Super @ 6 GB | Samsung 980 1TB | Windows 10 Pro x64 (22H2)
Try one of the latest builds from orphis build bot and check whether the problem persists.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction
You don't need AC5Z Plane Patcher since a year

Just make sure automatic game fixes are enabled.

Besides, your bug had already been reported.. but really, I can't reproduce it
Thank you for your fast responses. Yes, I acknowledged that it had been reported in the past but as I said, nobody had a fix for it so that doesn't help me. I tried the suggested remedies but unfortunately none of them had any effect. I decided to make a video showing all my settings and the gameplay itself. You'll see that without AC5Z, I couldn't hit the batteries or control towers. I actually installed AC5Z initially because I couldn't hit the Nimrods or warships in the mission "Narrow Line". AC5Z got me through that mission and I also needed it to play Ace Combat Zero. You'll see that after a couple of strikes, the bunkers stop respawning and the troops do not advance. I don't know what the problem is but I assure you that I'm not making it up. I really don't want to be a bother to anyone but I'm at my wits' end. If anyone can see what I'm doing wrong, please let me know, even if it's some boneheaded mistake I've made.

Here is the link to the video (Full 1080p so everything is crystal-clear):
You should make the video public first Tongue (or unlisted)
[Image: newsig.jpg]
(02-12-2015, 12:23 PM)Bositman Wrote: You should make the video public first Tongue (or unlisted)

That's odd, I thought I had set it as unlisted. I'll check it again. Sorry about that.

There, that should do it.
You shouldn't use boot cdvd (full), it's probably why the automatic game fix isn't working. Try again with fast
[Image: newsig.jpg]
(02-13-2015, 12:34 PM)Bositman Wrote: You shouldn't use boot cdvd (full), it's probably why the automatic game fix isn't working. Try again with fast

That did it! I knew it had to be something boneheaded on my part. You sir, are a genius! Thank you! Laugh
It just works here, even with full boot (important for me since it's the only way to not play in english)

I just checked game fix db, and I saw only SLUS-20851 and SCES-52424 (mine) have workarounds.
Perhaps you have another serial?

Users browsing this thread: 1 Guest(s)