Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolved-Workaround [Bug Report] Armored Core 2 [NTSC-U]
#1
# PCSX2 version:

PCSX2-v1.3.1-1525-g601d182
PCSX2-v1.3.1-1454-g91b2fd3
PCSX2 1.2.1 stable
PCSX2 1.0.0 stable

# CPU options:
Tested all without any effect on the bug effect

# Plugins used:
GSdx DX11 SW (whichever version came packaged with the build I mentioned), SPU2-X (whichever version came packaged with the build I mentioned, changed various settings to no avail), ZeroSPU 0.46

# Description:
Some sound go into an infinite loop, especially easy to reproduce in any mission that features jet fighters (let several in close proximity and start using a rapid fire gun and destroy one of them), not fixed by any settings nor manual game fixes, using ZeroSPU fixes it but introduces a 0.5-1 second delay on every sound, using the version of SPU2-X packaged with the 1.0.0 stable fixes the bug (tested a good dozen times and couldn't reproduce the bug with that version).

Sponsored links

#2
Can you please try to find the version of pcsx2 that broke the game?
You could do a binary search: check always the central revision between the earliest broken and the latest working revision. Like that you could find the broken revision within 10 trials. If you find the revision that broke the devs might be able to solve the problem.
#3
PCSX2 1.1.0.r5423 is the last version that doesn't have this bug.

EDIT: I apparently was an idiot and didn't test that thoroughly enough, the version that is the first to have this bug is actually PCSX2 1.1.0.r5418.
#4
could you check whether issues is present while using this version of SPU2-X plugin ? link

Testing this would be useful for finding the core of the issue.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
#5
It's still present.
#6
Take #2 on finding the issue : https://www.dropbox.com/s/jv8luaob9snfdp...X.dll?dl=0

make sure to also post the emulog.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
#7
(12-07-2015, 11:43 AM)ssakash Wrote: make sure to also post the emulog.

By emulog I assume you mean a copy of what's in the secondary window, do I need to activate any of the other sources or is the default enough?

EDIT: The problem is still here.


Attached Files
.txt   log.txt (Size: 2,62 KB / Downloads: 53)
#8
(12-07-2015, 11:59 AM)TransparentBlue Wrote: By emulog I assume you mean a copy of what's in the secondary window, do I need to activate any of the other sources or is the default enough?

EDIT: The problem is still here.

Hmm, log messages didn't get triggered. I'll try to get this game and push this issue. maybe sudonim might know on which part causes this issue.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
#9
Small update, the issue only happens when using a specific weapon against specific enemies and unlike what I originally thought it's not the rapid-fire weapon that causes the problem.

Maybe you would like me to provide a video and/or a memory card and a detailed explanation of how to reproduce it?
#10
(12-07-2015, 01:37 PM)TransparentBlue Wrote: Maybe you would like me to provide a video and/or a memory card and a detailed explanation of how to reproduce it?

yes, memory card save file and detailed explanation would be nice. video would also be a good addition Smile
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]




Users browsing this thread: 1 Guest(s)