Resolved-Workaround: [Bug Report] Mana Khemia 2 [NTSC-U]
# PCSX2 version: Official v1.0.0 release (rev5350)
# CPU options: EErec on, VUrec0 and VUrec1 on
# Plugins used: GSdx 0.1.16-r5334 (hardware and software, dx10 and dx9), spu2-x 2.0.0
# Description: during cutscenes some sprites may twinkle or dissapear. Tried also 0.9.8-r4600 - works fine.

Sponsored links

First try using the GSdx from 0.9.8 with 1.0.0, see where the problem lies
[Image: newsig.jpg]
(08-11-2012, 09:59 PM)Bositman Wrote: First try using the GSdx from 0.9.8 with 1.0.0, see where the problem lies

Tried it, sprites are still dissapearing.
Hm did you make sure all speed hacks are OFF? Also HW hacks in GSdx OFF
[Image: newsig.jpg]
Yes, speedhack off, hw hack off.
OK looks like a valid bug then. If you'd like to help, use the buildbot to pinpoint exactly when the game broke:
Track the exact revision by using the binary search algorithm so you test the lowest possible builds to find it.

Explained easily:

Let's say you have 1000 revs.You start at rev 500,test if the bug is there. If it's there, it means the bug was introduced before rev 500, so you test rev 250. If you get the bug, same thing etc etc.
If you test a build and the game works, you go the other way. So for example you test rev500 and it works. So the bug is between rev 500 and rev1000. Then you test rev 750 and so on and so forth
(you always choose min rev+max rev/2 to test, so 1000/2, 0+500/2, 250+500/2 etc )

So if the problematic rev was let's say rev 400 here is how it would go: Test rev 500->bugged. So the bug is between 0 and 500. Test rev 250->Works. So the bug is between 250 and 500. Test rev 375->Works. So the bug is between 375 and 500. Test rev437->Bugged. So the bug is between 375 and 437. See how we're closing up? Eventually you will get to rev 400
[Image: newsig.jpg]
I'm already looking for the problematic rev and it's even below r5032
Checked revisions, that I downloaded previously - it seems this bug is somewhere between r4790 and r4980.
pcsx2-4820 to pcsx2-4962
Still looking
It's a problem because you have to start the game from the beginning every time to be able to encounter the problem for sure

Edit:r4821 is the problem...there is no download link for it but r4818 works fine but r4822 have the problem(r19 and 20 are not pcsx2 builds and r4822 have have nothing to do with a problem of this kind)
Can somebody retest or tell me if this issue is resolved? Thanks.

Users browsing this thread: 1 Guest(s)