Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Resolved-Workaround: [Bug Report] Primal - Regressions since v1.7.0-dev-138
#1
I hope this is the correct section.

Happens on every render (DirectX11, OpenGL and even Software mode).

Some textures, like pillars or other pieces of the environment, don't show and others disappear depending on the distance from them. This is with the latest (as of yet) dev build (v1.7.0 437) and goes back quite a while. I've tried rolling back a few updates and it always happens, until I decided to go a few months back and found out that in dev build 1.7.0 138 the game rendered correctly, don't know exactly when the change that broke some textures has been implemented, but must have been after this build.

Unrelated - Is there a way to deactivate the PS2 depth of field effect? It looks horrible in 1080p. I've already tried with skipdraw settings, but they mess with the mist rendering. Maybe a patch that disables just the DOF?

Here are my settings:

Emulation settings - everything default, I let the automatic gamefixes take care of everything. Speed hacks are disabled of course.

Graphic settings - GSdx-32 AVX2, OpenGL, mipmapping full, CRC partial, DATE fast, blending high. Everything else is default.

Thanks

Sponsored links

#2
Enabling VU Kickstart hack will solve that, I am sorry it's not in the DB yet.
#3
(10-13-2020, 07:02 PM)Atomic83 Wrote: Enabling VU Kickstart hack will solve that, I am sorry it's not in the DB yet.

Where can I enable that? Is it in the Emulation settings? VU window, Speed hacks or Game fixes? I can't find it.
#4
It's at the bottom of the gamefixes tab

note that you need to be using the latest build to see this, 138 won't have it
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
#5
(10-13-2020, 08:36 PM)refraction Wrote: It's at the bottom of the gamefixes tab

note that you need to be using the latest build to see this, 138 won't have it

Great! That fixed it. Thank you all. So this fix will be included in the next dev build then? Good.
I've played almost to the end of the first world, and besides some fps decrease that depends from the GPU (the gtx 970 can't quite cut it with its 3.5 GB of ram at x3 resolution) the game seems to play perfectly.

Now all that remains is a patch to deactivate that bothersome dof and the game will be a beauty.

PS - I'm using a patch I've found in the ''Fixing unplayable games" thread, that allows the game to be played on the regular GSdx plugin HW mode without the black screen bug.
It works better than the GSdx specifically modded for Primal by prafull (maybe the modded plugin was a bit faster though), because some effects weren't correctly rendered with it (the "mist form" that the character assumes when she has less than half HP appeared as black textures, and the cutscene at the hospital after she dies was a rainbow-purplish texture mess). Even more with the modded plugin if you entered the graphic settings to adjust something the game would show garbage textures after, with the patch and the normal plugin everything works normally. So it might be an idea to add this patch to the code too.
#6
Thank you for your report.
This bug report has now been marked as Resolved with a workaround since it has been fixed on our code base.

This thread will now be closed and moved to the resolved bug reports subforum.
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 10 Pro 64bit




Users browsing this thread: 1 Guest(s)