Resolved: cmdline --elf broken?
I'm trying to load an ELF-file by commandline using :

pcsx2.exe --elf="D:\Emulators\pcsx2\ELF\file.elf" "D:\Emulators\pcsx2\ISO\file.iso"

Pcsx2 opens and loads the iso but it is using the ELF on the iso and not the ELF from the commandline input.

Output from console:
HLE Host: Will load ELF:

HLE Notice: ELF does not have a path.

Loading the ELF file by gui works, see console output :
HLE Host: Will load ELF: D:\Emulators\pcsx2\ELF\file.elf

HLE Host: Set 'host:' root path to: D:\Emulators\pcsx2\ELF\

I'm using R5248.

Thanks for help!

Sponsored links

I don't think PCSX2 supports loading an elf separately from an ISO. AFAIK it can only be made to load a single ELF file OR a single ISO file..
[Image: newsig.jpg]
Sorry for bringing up an old post, but I figured it's better than a new thread. I have a similar problem, or possibly the same one.

With PCSX 1.0.0 r5350, I'm trying to get it to auto-load an elf file through the command line, but nothing happens.

Here's the shortcut:

"C:\PCSX2\pcsx2-r5350.exe" --elf="C:\PCSX2\Games\file.elf"

When I try that, PCSX2 opens, but it doesn't load anything, and the console doesn't show that anything has happened.

When I load the elf through PCSX2's System > Run elf menu, everything works just fine. It just won't auto-load the elf file. Is this a bug, or am I doing something wrong?
Did that same procedure work for 0.9.8 or even in some 0.9.9 SVN?
[Image: newsig.jpg]
This is my first time trying to auto-load games through the command line, so 1.0.0 is the first build of PCSX2 I've tried it on. I suppose I can hunt down an older revision of PCSX2 and give it a shot later.
No need for hunting Tongue
SVN revisions:
[Image: newsig.jpg]
Okay, just tried PCSX2 0.9.8 r4600 and it doesn't work either. Is there an issue with my shortcut? I've also renamed the elf file a few times, though -- could that be the issue? EDIT: Although if loading the elf works via the menu, the filename shouldn't be the issue.
I've been wanting to use this feature too because I'm doing homebrew development and PCSX2 with host file system support is a more convenient way to test my programs.

However, looking through the source code I see this switch is simply being ignored by the emulator, and has never actually worked in any version before. Perhaps a dev can explain why? Are there problems with this feature or did nobody bother to implement it yet? Then why is it listed among the command line arguments?
any update on this? a bit frustrating that elf's can't be loaded from the command line.
C2D E8400 @ 4ghz
Asus Maximus Formula
G.Skill 4gb (2x2gb) @ 1000mhz
XFX 5870 1gb
Intel X-25m 160GB SSD
Windows Vista Ultimate 64-bit
Dell 30" 3007wfp
I tried this with the stable 1.2.1 PCSX2 version and it didn't work, but it does work in the lastest git revision.

Thank you for your report.
This bug report has now been marked as Resolved since it has been fixed on our code base.

This thread will now be closed and moved to the resolved bug reports subforum.

Users browsing this thread: 1 Guest(s)