Road Rage 3 Running Slowly?

Has anyone had any luck with the European release Road Rage 3?

I've tried running it in software mode as well as DX9, DX11 and OpenGL hardware.  The game loads fine and I don't see any graphical glitching but once in-game it all runs really, really slowly.

I had a look in the compatibility table on the main site but it doesn't have an entry.  I also looked under its Japanese name (Touge 3) but that doesn't have an entry either.

Thanks in advance for any advice. Smile

EDIT: I'm running Git build 9c8b5e3 from a couple of days ago. I'm also on Win 7 64bit Pro with an i7 4770k and a GTX 780 GPU.

Sponsored links

[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Everything is on default. I didn't want to mess around with stuff I didn't understand! Smile
How slow is very,very slow exactly?

Is there a noticable inprovement when turning on the MTVU speedhack(Config > Emulation Settings > Speedhacks tab) and rendering threads for software mode(Config > Video (GS) > Plugin Settings)?
The game runs in single digits. It's like playing in slow motion.

I tried all the preset speedhack settings and I tried just upping EE cycle rate and VU cycle stealing but nothing makes any real difference though the game did speed up by a few frames with the preset "Mostly Harmful".

I guess the game just doesn't work under PCSX2...
I'm having essentially the same issue with this game. In a typical race, the game runs far too slow to actually be playable. In a single player time trial, the game will actually alternate between extended periods of 10+ seconds of running fine and then 10+ seconds of being unplayably slow.

Software mode on the video plugin has no impact. Hard to really tell if any of the speedhacks have any impact, but if they do, the impact is well short of actually fixing the problem.

PC Config: Win 10, i5 4690K, GTX 970. Using the 1.4.0 stable build of PCSX2.
First, can you try the latest git build and see if the problem still exists?
Sorry. Yes. I actually did that immediately after my previous post and forgot to go back and edit it.

I'm seeing the same behavior. I tried the same gamut of stuff to fix it (s/w mode, speedhacks), and they had no noticeable impact.

Users browsing this thread: 1 Guest(s)