Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Rogue Galaxy Issue -- Factory not displaying [Solved]
#1
**Update Three** -- I'm a dumbass.

**Update Two**
Adding my memory card, the first save is the boss fight right before you unlock the factory. The 2nd save is right after you unlock it.

**Update One**
I have a copy of the correct dvd9 version of this game, the hashes match those of this copy: http://redump.org/disc/6567/
I played for about 10 hours during the night to get back up to where you gain access to the factory only to have the same problem again. I have tried the latest SVN build and 0.9.8. In the code tags below you'll find my logs from the time I click on Factory to about a second or two after. With this new image that is an exact copy of the original discs, I'm still having the issue. Which is pretty much making the game unplayable in a way. If I'm the only one that has ran into the problem (which is kinda strange) then maybe there's some sort of setting I could try tweaking or something. Everything in the logs is the same as what was in the other copy of the game however I did enable logging CDVD reads. Any ideas? =/

In original post
When I chose factory in the menu it's not showing me the factory menu or taking me to the factory or w/e it's supposed to do. It just sorta freezes when the "linking to the factory via remote control..." text appears. I've tried fiddling with all the different settings toggling on off just about everything that there is. Tried using different graphics plug-ins but I don't think it's related to that. After selecting it, the music just keeps playing and it doesn't exactly appear to "freeze" the actual application, I'm not sure what exactly it's stuck on. I don't see any sort "errors" in this code but I'm not real sure what to look for in that regard anyway. I'm able to load from a save stated after clicking the menu option so the client itself doesn't appear to be freezing. Any ideas?

Application Version: 0.9.8
GS: GSdx 4600 0.1.16 (have tried SSE2 and SSE41 and SSSE3, all same problem)
LilyPad 0.10.0 r4510
SPU2-X 1.4.0 r4600m

Windows 7 64 bit
i7 9600 @ 3.0 GHz (tried setting to default clock speed to see if that made any difference, it didn't -- 2.7 GHz)
nVidia GTX 260

Code:
Protected page @ 0x001b9
Protected page @ 0x001b8
Pagesplit @ 001B8FFC : size=1 insts
Protected page @ 0x00165
Protected page @ 0x0020f
Protected page @ 0x00210
Protected page @ 0x00166
Protected page @ 0x00135
Pagesplit @ 00182FF8 : size=2 insts
DvdRead: Reading Sector 693731(5 Blocks of Size 2064) at Speed=4x
Pagesplit @ 00294FE0 : size=8 insts
Protected page @ 0x0028d
Protected page @ 0x00410
Protected page @ 0x00411
Protected page @ 0x00408
Protected page @ 0x0040a
Protected page @ 0x003fd
Protected page @ 0x00406
Protected page @ 0x003ff
Protected page @ 0x00400
Protected page @ 0x003f6
Protected page @ 0x003f7
Protected page @ 0x0040b
Protected page @ 0x00405
Protected page @ 0x00424
Protected page @ 0x00425
Protected page @ 0x0042f
Protected page @ 0x00369
Pagesplit @ 00405FFC : size=1 insts
Protected page @ 0x0040e
Protected page @ 0x003eb
Protected page @ 0x003e7
Protected page @ 0x003ed
Protected page @ 0x003e4
Protected page @ 0x003b0
Protected page @ 0x003a8
Protected page @ 0x003af
Protected page @ 0x003aa
Protected page @ 0x003ad
Protected page @ 0x003f5
Protected page @ 0x003ae

[Image: roguegalaxyproblem.png]


Attached Files
.zip   RogueGalaxyTryTwo.zip (Size: 67,03 KB / Downloads: 67)
Reply

Sponsored links

#2
All I can say is to try one of the latest SVNs and see if that works for you as version 0.9.8 is a bit old by now and there have been a number of changes since and one of them may help with your issue.

You can find them here http://pcsx2.net/svn.php
Reply
#3
Oh thanks, didn't know where to find them, the beta info on the site was way outdated so I wasn't sure it was public yet. Guess this isn't really "beta" stages yet though probably.
Reply
#4
Same issue in the latest SVN unfortunatly, in the logs this is the only thing that shows up in the SVN (0.9.9.5103 feb 22 release) after I click on the Factory menu item. It does the same thing as 0.9.8, music just keeps playing, no real "freeze". It's just nothing happens once you click it besides that text.

Code:
Pagesplit @ 00294FE0 : size=8 insts
Pagesplit @ 00405FFC : size=1 insts
Protected page @ 0x003e7
Reply
#5
Hmm could be a disc image issue then if your playing from an image try the disc itself and see if that fixes the problem
Reply
#6
Check your games hash http://redump.org/discs/quicksearch/rogue-galaxy/ since I'm not sure what your game region is, pick one yourself.

You can hash your image with software like this http://keir.net/hash.html (16KB portable, just drag and drop the image file).
Reply
#7
I don't see "my" hash on that site, I converted the MDS image to an ISO because I wasn't sure how to load the MDS file into the emulator. I used a freeware app called LCISOCreator to convert it, which worked great and has worked fine with other games as well.

The original MDS file I have has the following hash info
Size: 4339 bytes
MD5: 7D7AF91E3C7BC5395CD8715EDA74C23D
SHA1: 7FB57AD99DA02B2082CDA3770D7241A6752B64F1
CRC32: DFA1B656

The ISO I made
Size: 4657971200 bytes
MD5: 75DD621BD45AE77E40A795B7A6D77E9B
SHA1: FF5934CD12D05CBF686D9C3F803C99D5270AA3EF
CRC32: 1A351434

Not entirely sure how MDS files are able to "hide" the actual filesize, it's a little weird.

I'm assuming by the link that you're inferring something to the effect that I should be playing with a copy that has the same hash as the original copies of the game.
Reply
#8
*.MDS files are like *.Cue files. It contains the Table of Content of what the MDF file holds. Also always rip your games with IMGBurn Smile it's one of the better programs for it.
Reply
#9
That mean your image is corrupted, go do as strife79 said and re-rip your game using imgburn.

Also, Rogue Galaxy is a DVD-9 game, with total size of 6967721984 Bytes for the NTSC version of the game as that convenient site informed, your copy is probably a bootleg or you've been deceived.
Reply
#10
(02-23-2012, 06:20 PM)StriFe79 Wrote: *.MDS files are like *.Cue files. It contains the Table of Content of what the MDF file holds. Also always rip your games with IMGBurn Smile it's one of the better programs for it.

Nope, cue files tend to also contain track lists, the MDS is a description file only. TOC, Track list and sub data are all stored in the MDF.
Reply




Users browsing this thread: 1 Guest(s)