Running ISO help.
I know by the title this looks like a post that is an incredibly oblivious noob trying to learn how to use ISO's. This isnt the case. Ive successfully played many games on PCSX2. Although i've been experimenting, and trying new things. Last night i found my box of old ps2 games, Ico and Megaman X8 were among them. Upon checking the compatibility list, megaman x8 is the only fully playable one. Long story short, i extracted megaman x8 as an ISO and it will not open on the emulator. I get a black screen with no sounds. If this is a common problem, please point me in the right direction.

Ive played around with all the video plugin settings, but nothing has worked yet. Any help would be appreciated, and also. Awesome job developers! A ps2 emulator, no a WORKING ps2 emulator is simply amazing.

*EDIT*-I got FFXII to work along with DBZ Budokai 3. I am using USA bios v. 2.0. My old ps2 takes like 20 tries to read a disc, and i use a ps3 controller as a game pad, so if i could get these to work on my computer, that would make me a very interested patron. Not to mention happy.

Sponsored links

On my last test of this game (in March this year), I got playable status using these plugins and settings:

Quote:Beta Date: 26 02 2009 0.9.6 RC Final
Conditions Tested Under:

GSdx 890 SSE3 [10 02 2009]
LilyPad 0.9.9 [06 02 2009]
Linuz Iso CDVD 0.8.0 [20 02 2009]
USBnull Driver 0.5.0 [15 04 2007]
SPU2ghz Playground 1.9.0 [05 12 2008]
DEV9null Driver 0.3.0 [15 04 2007]
FWnull Driver 0.4.0 [16 05 2005]
USA v02.00(14/06/2004) Console
DC and MTGS | VU1Rec and VU0Rec | rCache 0 | Console 1 | Patches 0

Status is unchanged. Runs stable and much faster now.

Intel Core i7 920 @ 3.4 Ghz | 6 GB DDR3 RAM in Triple Channel | GeForce GTX 285
2.5 TB Hard Drive Space | Windows 7 Ultimate x64

Official betatester of PCSX2

I had this same problem when running FF12 ISO. The ISO plugin just doesn't regcognise the ISO file.

I mounted the ISO to a DVD emulator and used the normal DVD plugin, and it worked fine. Make sure you mount with a program like Deamon Tool Lite, not PowerISO. For some reason, PowerISO mount the image file as a CD and this is why the DVD plugin cannot read.

Hope this helps
never use a mounted image file with pcsx2, rip your game disc with imgburn and use linuziso as your cdvd plugin or the "file->run iso image" command to start them. if your ff12 iso isn't correctly recognised, then it's either not a proper iso file or a misconfiguration of your pcsx2/plugin.
CPU Core [email protected] | GPU Nvidia Geforce GTX 570 | RAM 8GB DDR-3 1600MHz CL9 | OS Win7 Ultimate (x64) SP1
EMU PCSX2 v1.1.0 r5645 | GS GSdx SSE4 r5632 | SPU2 SPU2-X r5559 | PAD LilyPad r5403 | CDVD cdvdGigaherz r5403
well, the thing is using mounted image file was the only thing that worked for me this time. My spec is slow so after trying burning this game a few times, i just didnt want to try anymore. My other DW series work fine with image files.
Thanks for all of the quick responses. I am going to switch to daemon tools rather than PowerISO that i have been using for other games. My main concern is megaman x8 right now. I changed all my plugins to what generalplot recommended. After setting up daemon tools i will post back with results. Thanks everyone again!

*Edit*-when i use the CDrom plugin : Linuz Iso CDVD 0.8.0

I get the error that it cannot read the ISO, followed by the error message:

Error opening CDVD plugin.

SECOND EDIT****- i somehow got it working....? I mounted a different so confused. Sorry!
alright so its obvious what the problem was. Thanks generalplot, your settings worked flawlessly. I had the iso mounted, and i was also trying to read it, i guess just a conflict of use. Thanks for all the help!

Users browsing this thread: 1 Guest(s)