Running pcsx2 with open source ati driver
Is it possible? I'm running Arch Linux using the xf86-video-ati driver. Is it possible to get it running using this? Whenever I try to run anything I get a crash with the error "Failed to create the opengl context. Check your drivers support openGL 3.3. Hint: opensource drivers don't". Is there any way to work around this? Even if it doesn't perform as well.

Sponsored links

You know, I ran into this problem myself. Supposedly xf86-video-ati should be supporting OpenGL 3.3 by now, but it's likely that code hasn't made its way downstream to the arch repositories yet. You may have no choice but to install catalyst or wait for an update to the open source drivers. I was able to get PCSX2 working fairly well under catalyst.
"I know now why you cry... but it is something I can never do."
-Emotion Engine
Alright well if there's no way around it (other than catalyst) I guess I'll just wait it out. No big rush.
Mesa-10.1 will be released soon (it's at release candidate 2 right now), it provides OpenGL 3.3 for radeon. The thing is though, it should work already, I had it working on Haswell when there was only OpenGL 3.1 support for it.

Until mesa-10.1 is released you can try the ZZOgl plugin, but you need to compile it *without* GLSL. Which means use ABS and modify the PKGBUILD, you have to remove GLSL_API from the cmake line.
Sadly, I ran into the same problem last night with Antergos/Arch. Thought I found a great distro except for the problem with difficulty installing fglrx, and some of the emu's in the repos were too unstable. There is not much you can do but change distros if you feel like it, or sit back and wait for things to hopefully correct themselves.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti

I commit a new version on svn. I didn't test any but set the option "reduce_gl_requirement_for_free_driver" to 1 in GSdx.ini. If you're lucky it might work
Thanks. I was trying to recompile and I got these errors though:

In file included from /usr/lib/gcc/x86_64-unknown-linux-gnu/4.8.2/include/x86intrin.h:27:0,
                 from /usr/include/c++/4.8.2/x86_64-unknown-linux-gnu/32/bits/opt_random.h:33,
                 from /usr/include/c++/4.8.2/random:51,
                 from /usr/include/c++/4.8.2/bits/stl_algo.h:65,
                 from /usr/include/c++/4.8.2/algorithm:62,
                 from /home/daniel/build/pcsx2-svn/src/pcsx2/pcsx2/DebugTools/DisassemblyManager.cpp:4:
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.8.2/include/ia32intrin.h: In function ‘long long unsigned int __rdtsc()’:
/usr/lib/gcc/x86_64-unknown-linux-gnu/4.8.2/include/ia32intrin.h:95:1: error: redefinition of ‘long long unsigned int __rdtsc()’
__rdtsc (void)
In file included from /home/daniel/build/pcsx2-svn/src/pcsx2/common/include/Pcsx2Defs.h:35:0,
                 from /home/daniel/build/pcsx2-svn/src/pcsx2/common/include/Utilities/Dependencies.h:193,
                 from /home/daniel/build/pcsx2-svn/src/pcsx2/pcsx2/./PrecompiledHeader.h:27,
                 from /home/daniel/build/pcsx2-svn/src/pcsx2/pcsx2/DebugTools/DisassemblyManager.cpp:1:
/home/daniel/build/pcsx2-svn/src/pcsx2/common/include/intrin_x86.h:846:69: error: ‘long long unsigned int __rdtsc()’ previously defined here
static __inline__ __attribute__((always_inline)) unsigned long long __rdtsc(void)
pcsx2/CMakeFiles/pcsx2.dir/build.make:1977: recipe for target 'pcsx2/CMakeFiles/pcsx2.dir/DebugTools/DisassemblyManager.cpp.o' failed
make[2]: *** [pcsx2/CMakeFiles/pcsx2.dir/DebugTools/DisassemblyManager.cpp.o] Error 1
CMakeFiles/Makefile2:281: recipe for target 'pcsx2/CMakeFiles/pcsx2.dir/all' failed
make[1]: *** [pcsx2/CMakeFiles/pcsx2.dir/all] Error 2
Makefile:116: recipe for target 'all' failed
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
fixed in r5913.

Users browsing this thread: 1 Guest(s)