SCP Used to work, now it doesn't
I've been using the SCP drivers for a while now, and everything was fine and dandy until I did something with Zadig for the official Wii U Gamecube controller adapter which was WUP 028.

SCP installs fine, my 360 driver is up to date and installed correctly, but my PS3 controller shows up under Unspecified in Devices and Printers. On top of that, the SCP monitor just shows my controller as charging. Any help or ideas would be greatly appreciated.

Sponsored links

If you haven't already, try to reinstall it. Open SCPDriver and uninstall it all, restart computer, reinstall it. If that doesn't help; you can try going into the device manager window to force the DS3 to use the SCPDriver... drivers. To do this, you'll need to find the DS3 controller in device manager, no idea where it would be since it appears to be Unspecified, but take a good hard look. Once you've found it, right click it and hit update driver software. Then hit Let me pick from a list of device drivers on my computer and find BTH DS3 Device, or something similar to that. Might by SCP DS3 Device.

Good luck.
Have you tried the DS3 reset button?
I've already tried reinstalling it but no luck. It will identify the controller as PLAYSTATION® 3 Controller in my devices, but all it will do is charge. Resetting the controller did nothing.
If it shows up as Playstation 3 Controller, I believe SCPServer hasn't been installed. When it's installed you should see Xbox 360 Controller. Try to install it as it is now, if not, force the driver installation by going into the device manager.
I got it to work somehow. I did two things, but I'm not exactly sure which one did the trick. I stopped and resterted the SCP DS3 Service in the Services window from the Control Panel, and I updated my 360 controller drivers to a driver that is more recent. Thank you guys for the help, and I hope that anyone else with similar problems may learn from this thread.

Users browsing this thread: 1 Guest(s)