SCP driver issue
Hello everyone,

I´ve come looking for a possible solution to my issue:

I have been using SCP service to make my PS4 controller work on w10 for quite some time, but for some reason it stopped working recently. What I did was mess around in the scp driver installation software, installing and uninstalling drivers for the "Wireless controller" that pops up after plugging in the PS4 controller. Since I couldnt get it to work I tried uninstalling the USB port that the controller was plugged into, thinking there may be some left over data on it? I have no idea what I am doing, hence this post.

Now the controller comes up as unknown device when being plugged in with an error "A request for the USB device descriptor failed. (code 43)". The same error appears when its being plugged into different USB ports as well. I have tried forcing driver installation onto the "unknown device" a couple times, and sometimes it made the controller work, but only until it was unplugged again.

I´ve additionally performed full scp driver wipe twice already. Also checked with all the driver softwares, there is no remnant of SCP buses or anything in the PC.

Is there some way to fix this so I can actually use the controller and so it comes up as a wireless controller underneath Windows again?

Many thanks for any feedback.

Sponsored links

Users browsing this thread: 1 Guest(s)