Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SMT 3 Nocturne glitches?
#1
I'm getting some serious glitches when using hardware renderer with both, Direct3D11 and OpenGL. Only when I switch to software renderer it works, but then I cannot upscale textures and the game looks really bad in comparison.
[Image: a1L7L2s.png]
The soul should not be visible through the wall. I get similar seemingly depth related issues when for example I stand behind an object like a bed but it loks like I am standing ontop of it.
Light shafts are usually in the foreground and eclipse objects instead of being on the ground and the objects being in the foreground.
I went through literally every graphics and gamefix option one by one but nothing fixes it.

I get this kind of glitch (copied from the PCSX2 wiki):
Glitchy character shadows
  • Workaround: Go to Config > Video (GS) > Plugin Settings, and set Renderer to "OpenGL (Hardware)". Or switch to Software Mode by setting Renderer to any of the "(Software)" options. Alternatively for Direct 3D9 and 11 (Hardware), go to Config > Video (GS) > Plugin Settings, set CRC Hack Level to "None", turn on "Enable HW Hacks", go to Configure Hacks and enable the "Alpha" hack. This, however, will make NPCs, some objects and shadows cast by object visible through walls. Also you can use a .pnach file that removes shadow from the main character. It does not affect objects, walls and NPCs, so it has advantage over the previous method.
I get the result but I don't have the settings.
I got almost everything set to default (all emulation settings except window size are default but I locked it to 4:3 ratio):
[Image: Tf3K1mo.png]

I tried switching around, like trying partial CRC hack recommended for OpenGL with and without Hardware Depth / Accurate Date but nothing so far worked.
Intel i5 3.4 GHz Quadcore
Nvidia GeForce 1060 GTX 6GB
8GB Ram
Windows 7 Home Premium
Reply

Sponsored links

#2
Try dev builds and see how it is.
https://buildbot.orphis.net/pcsx2/
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply
#3
I had the the same problem (some things being visible through walls) and fixed it by unchecking the 'Full Depth Emulation' box (under Config > Video (GS) > Plugin Settings).
(NixOS, OpenGL (Hardware) renderer)
Reply
#4
I played this game SMT nocturne without any problem. I am using  pcsx2 1.5, directx 12,
updated nvidia driver and default video plugin for pcsx2.
CPU : I7 6700 3.4 Ghz
GPU : Gigabyte Geforce GTX 1050 TI
SPU : Realtek High Definition Audio
RAM : 16 GB
Os : Windows 10 64 Bit
Emulator : PCSX2 1.5 
Reply
#5
(06-22-2018, 05:58 PM)teots Wrote: I played this game SMT nocturne without any problem. I am using  pcsx2 1.5, directx 12,
updated nvidia driver and default video plugin for pcsx2.


I wonder where you got this so called PCSX2 version with Direct3D 12 support.
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply
#6
(06-22-2018, 06:30 PM)lightningterror Wrote: I wonder where you got this so called PCSX2 version with Direct3D 12 support.

PCSX2 1.5 can be found at this website and directx12 can be download from Microsoft or you can search for it at google.
BTW your last 1 & 2 avatar look better or you use this current avatar because you look like the lady ?
CPU : I7 6700 3.4 Ghz
GPU : Gigabyte Geforce GTX 1050 TI
SPU : Realtek High Definition Audio
RAM : 16 GB
Os : Windows 10 64 Bit
Emulator : PCSX2 1.5 
Reply
#7
PCSX2 doesn't use DX12 so that doesn't matter...
Reply
#8
(02-19-2018, 02:48 PM)Megidolaon Wrote: I'm getting some serious glitches when using hardware renderer with both, Direct3D11 and OpenGL. Only when I switch to software renderer it works, but then I cannot upscale textures and the game looks really bad in comparison.
[Image: a1L7L2s.png]
The soul should not be visible through the wall. I get similar seemingly depth related issues when for example I stand behind an object like a bed but it loks like I am standing ontop of it.
Light shafts are usually in the foreground and eclipse objects instead of being on the ground and the objects being in the foreground.
I went through literally every graphics and gamefix option one by one but nothing fixes it.

I get this kind of glitch (copied from the PCSX2 wiki):
Glitchy character shadows
  • Workaround: Go to Config > Video (GS) > Plugin Settings, and set Renderer to "OpenGL (Hardware)". Or switch to Software Mode by setting Renderer to any of the "(Software)" options. Alternatively for Direct 3D9 and 11 (Hardware), go to Config > Video (GS) > Plugin Settings, set CRC Hack Level to "None", turn on "Enable HW Hacks", go to Configure Hacks and enable the "Alpha" hack. This, however, will make NPCs, some objects and shadows cast by object visible through walls. Also you can use a .pnach file that removes shadow from the main character. It does not affect objects, walls and NPCs, so it has advantage over the previous method.
I get the result but I don't have the settings.
I got almost everything set to default (all emulation settings except window size are default but I locked it to 4:3 ratio):
[Image: Tf3K1mo.png]

I tried switching around, like trying partial CRC hack recommended for OpenGL with and without Hardware Depth / Accurate Date but nothing so far worked.

I had the same issues, switch to the beta, this is an issue with stable GSdx. Also the beta adds an auto CRC hack option to GSdx that works wonders for this game in particular. I've been able to get full speed with absolutely no hitches whatsoever, even in the tutorial tunnel where everything usually starts to slow down because of the insane amount of particle effects in the area.
Reply
#9
Worse than any glitch is the MASSIVE amount of motion blur (ghosting) this game produces on PCSX2. Unfortunately there's no interest in fixing this.

A custom plugin was developed by someone to tackle this issue, however it only works up to version 1.2.1. Message me if you're interested.
Reply
#10
(07-02-2018, 08:58 PM)Draconic Seed Wrote: Worse than any glitch is the MASSIVE amount of motion blur (ghosting) this game produces on PCSX2. Unfortunately there's no interest in fixing this.

A custom plugin was developed by someone to tackle this issue, however it only works up to version 1.2.1. Message me if you're interested.

Ghosting can be resolved by using one of the Half-Pixel offset/Wild Arms Hack in the GSdx HW Hacks section and/or Large Framebuffer.
Reply




Users browsing this thread: 1 Guest(s)