[SOLVED] Disgaea hour of darkness problems, won't start
I am running it from an .iso, from the disc it makes no difference. Basically when starting Disgaea hour of darkness, it starts up fine, with the standard ps2 startup screen (the blueish smokey screen with cubes and abstract stuff everywhere), then just shows a black screen with a grey box in the middle. I haven't been able to get past this into the actual game itself.

Also, God of War works on PCSX2, albeit slowly.

My specs

Intel Core 2 Duo E6600 2.4gHz
2gb RAM
GPU: Nvidia GTX 275

my PCSX2 settings
I have tried ZeroGS 0.97.1 as well, and it gets to the same spot and shows a grey box with the 'Playstation 2' words flickering on it for a second, then just the grey box again. Also, the FPS is in the hundreds with the grey box, but only around 10-11 when the letters playstation 2 show up.

Oh, and if I run it and get to the grey box point mentioned above, and press ESC and reset, then start it again, it instantly crashes PCSX2.

This is the USA release of Disgaea 1 as well, and my BIOS is the USA one.

Thanks in advance.

Sponsored links

i had this problem with a few games.
i was using gsdx 9 instead of 10, i run windows vista and my card supports direct x 10 so i ran that instead and it went sweet.
it seems with gsdx 10 you get less graphical glitches, i dunno does your card support dx10?
god of war will be quite cpu hungry and with your current cpu you might not get decent speeds, i would suggest overclocking your cpu but not alot of people know how to do this.
also you can try speed hacks in the config tab to x2 see if you get a performance boost.
you can also try knocking down your d3d res to somthing like 640x480, looks ugly i know but i got a good performance boost from that.
hope this helps, im new to the pcsx2 thing aswell and just putting across what i have learnt. Smile
also i see you are running the 0.9.6? version you can try the beta versions here
and the beta plugins here
because you are running version 0.14 i think versions 0.15 & 0.16 are out

sorry for the double post Sad
about disgaea : use file/run CD/DVD instead of Run/Execute
about god of war : your cpu's a bit slow for this intensive game. A few speedhacks and overclocking may help though.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Well, the slowdowns in God of War are no problem for me, it's just getting disgaea to work is the issue. My card supports dx10, although I normally run XP. I do dual-boot Windows 7 though, so I will try it in dx10. Hopefully that will work.

OK, so first trying file/run CD DVD instead of Run/Execute, it just shows a black screen, nothing else. In the console, the last message (and only message after initialising the game) is

"EE NisPackedIrx.c< 149> : error"

I will try in dx10 on windows 7 later, but I don't think it is a graphical error anymore. I could be wrong though.

EDIT: PROBLEM SOLVED, I just had to switch from Linuz ISO CD plugin to Gigaherz, and it works, no problems so far!!! Thanks for the help anyways. This is in dx9 on Windows XP with the same settings in my original post except for CD DVD plugin.
oh, I bet you mounted your Iso in Daemon tools or other 3rd party software while using Linuziso.
Linuziso works alone, and you don't have to mount your file in another software.

anyways, as you said, problem solved->thread closed
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

Users browsing this thread: 1 Guest(s)