Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SSX3 [NTSC-U] Graphic Bug
#1
# PCSX2 version used: 1.3.1-20150925215010

# Emulation options: Everything set to default on the Safest preset. No hacks used.
# Plugins used: GSdx32-AVX, using the D3D9, D3D11 (Software and Hardware modes) and Open GL (Hardware). All settings turned off except for when I tested it with Hardware Depth checked while testing it with Open GL

# CPU: AMD Athlon X4 760K overclocked at 4GHz
# GPU: AMD Radeon R7 265


# Description: Multiple "Bar" graphic artifacts are interlaced vertically across the screen while in hardware mode. However, this issue seems to be solved ONLY in Open GL whenever 'Hardware Depth' is checked. This option is not available while rendering with Direct X. This opinion does not appear in any of the game menu's nor in any per-rendered videos.

#Screen shots:

Here is how it looks like while it software mode

[Image: qaKjj8Q.png]

Similar part of the game, but now rendered in DX11 Hardware mode (appears the same in DX9) with red bars across the screen.

[Image: 8OQFTqJ.png]

When rendered in Open GL, similar bars appear, but now in a distorted greenish shade

[Image: 8b2WfMD.png]

This is solved in Open GL whenever Hardware Depth is selected. Running in Open GL however isn't ideal for myself and probably others since my computer doesn't have a great CPU or GPU for emulator's. The game run's fine in DX11 mode, but not that great in Open GL.

[Image: RPLpwNA.png]

#GS Dump: https://www.dropbox.com/s/jzeyp47hhda4da...1.zip?dl=0
Reply

Sponsored links

#2
If it runs fine in opengl & software mode, moved out of bug reports
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
This D3D11 exclusive bug has already been reported on the Git Issue tracker, Thanks for the help though.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#4
(10-05-2015, 06:09 AM)thebonniebear Wrote: [Image: RPLpwNA.png]


Curious: Is it normal for that 7up billboard to be rendering upside down? And does it in software?
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#5
in opengl, enable hardware depth, if that doesn't help, try using some accurate blending.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#6
(10-05-2015, 06:21 PM)refraction Wrote: in opengl, enable hardware depth, if that doesn't help, try using some accurate blending.

the OP seems to be aware of it :p

OP Wrote:This is solved in Open GL whenever Hardware Depth is selected. Running in Open GL however isn't ideal for myself and probably others since my computer doesn't have a great CPU or GPU for emulator's. The game run's fine in DX11 mode, but not that great in Open GL.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#7
whoops, didn't see that Tongue
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#8
These red bars can be turned off with skipdraw in DX11.

@ Blyss Sarania: Yes, the 7up is supposed to be upside down. The bottle next to the logo is the right way up, and it is the same in SW as in HW.
Reply
#9
Isn't that an interlacing issue? I usually get it at random when I force progressive mode in certain games
Reply
#10
(10-21-2015, 06:51 PM)nachash Wrote: Isn't that an interlacing issue? I usually get it at random when I force progressive mode in certain games

Red lines are a result of bad blending.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply




Users browsing this thread: 3 Guest(s)