Samurai Champloo: Sidetracked - upscaling not working correctly
#1
This is quite a bizzarre situation that I never encountered with any other game on PCSX2. The upscaling seems to work on the character selection screen; However, as soon as I go in-game, everything is rendered at base resolution. 

[Image: Screenshot-487.png]
[Image: Screenshot-488.png]

This is also true of the tutorial mode. I wonder what might be causing this? These are my specs:

Operating System
Windows 10 Home 64-bit
CPU
AMD Ryzen 7 3700X 37 °C
Matisse 7nm Technology
RAM
32,0GB Dual-Channel Unknown @ 1799MHz (16-18-18-38)
Motherboard
Micro-Star International Co. Ltd. MAG B550 TOMAHAWK (MS-7C91) (AM4)
Graphics
SAMSUNG (3840x2160@60Hz)
4095MB NVIDIA GeForce RTX 3060 (ASUStek Computer Inc) 42 °C
Storage
1863GB Sabrent Rocket 4.0 Plus (Unknown (SSD))
1862GB Western Digital WD Elements 25A1 USB Device (USB (SATA) ) 28 °C
2794GB Western Digital WD Elements 107C USB Device (USB (SATA) ) 31 °C
1397GB Western Digital WD Elements 25A2 USB Device (USB (SATA) (SSD)) 27 °C
Optical Drives
HL-DT-ST BDDVDRW CH30N
Audio
NVIDIA High Definition Audio

This is my emulator log: 


.txt   emulog.txt (Size: 4,79 KB / Downloads: 46)
Reply

Sponsored links

#2
Quote:Samurai Champloo Sidetracked (UNDUB).iso
do you get the same problem without patching your game with the undub patch ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Reply
#3
(02-02-2023, 03:17 PM)jesalvein Wrote: do you get the same problem without patching your game with the undub patch ?

Yes, my bad, I should have posted the original. Here's the updated emulator log (the screenshots would look the same)

.txt   emulog.txt (Size: 7,51 KB / Downloads: 72)

EDIT: I did some more testing. Upscaling does work as intended in certain cutscenes, and in certain minigames (though it leads to some other problems; for example, in the all-you-can-eat minigame, the countdown numbers are not displayed correctly when upscaled)

[Image: Screenshot-498.png]
[Image: Screenshot-501.png]
[Image: Screenshot-502.png]

I recorded a couple of videos in Chapter 2 to show this; in the first one, you can see the upscaling works correctly at the beginning of the cutscene, and it abruptly stops midway through after an image is shown, and then how it works again when entering the minigame. In the second one, you can see how upscaling won't work in-game, but when entering trance mode it suddenly does. (Also the footage I recorded is de-interlaced) 
https://www.mediafire.com/file/18d5l16x2...6.mp4/file
https://www.mediafire.com/file/tiqfvikjy...7.mp4/file
I did not include that in the videos and I don't know how useful it might be, but if I place a save state during a scene where the upscaling is working, and load it from a position in which the upscaling is not working, it will still be at base resolution.

I've also updated the emulog though I don't think it'll make much of a difference. Keep in mind I was using Vulkan but this happens with all hardware renders. 

.txt   emulog2.txt (Size: 7,99 KB / Downloads: 50)

EDIT 2: The latest update of PCSX2 fixed this issue
Reply




Users browsing this thread: 1 Guest(s)