Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Samurai Warriors 1 - vertical lines
#1
Hello, there are 7 vertical lines on the screen when playing this game upscaled. It seems that this is a common problem of all Musou Warriors games, as you can see in these threads:

https://github.com/PCSX2/pcsx2/issues/2614

https://forums.pcsx2.net/Thread-Vertical...Warriors-5

https://forums.pcsx2.net/Thread-Dynasty-...s-6-issues

https://forums.pcsx2.net/Thread-Warriors...distortion

I've tried all the suggestions in the threads but nothing helped.

Since the PS2 Musou franchise was hugely popular (in Japan and Greater China, every gamer around my age has played or at least heard of it), is it not strange that this common problem doesn't have a fix yet??

It does not affect gameplay but I am working on a video project on the game at the moment so I am desperate to get rid of these ugly lines.

Any help would be appreciated.


Attached Files Thumbnail(s)
   
Reply

Sponsored links

#2
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(06-18-2021, 09:54 PM)jesalvein Wrote: Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Not sure if it makes any difference since I've tried Direct3D11 and OpenGL and various HW hacks but they didn't help at all. The only way to make the lines disappear is to play in software mode but I can't stand the blurry mess.


Code:
PCSX2 1.6.0-20200506140834- compiled on May  6 2020
Savestate version: 0x9a0e0000

Host Machine Init:
Operating System =  Microsoft Windows 10 Pro (build 19043), 64-bit
Physical RAM    =  16315 MB
CPU name        =  Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz
Vendor/Model    =  GenuineIntel (stepping 03)
CPU speed        =  3.499 ghz (8 logical threads)
x86PType        =  Standard OEM
x86Flags        =  bfebfbff 7fdafbbf
x86EFlags        =  2c100000

x86 Features Detected:
SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. AVX2.. FMA

Reserving memory for recompilers...

Loading plugins from C:\Program Files (x86)\PCSX2\plugins...
Bound  GS: GSdx32-AVX2.dll [GSdx 20200506140834 (MSVC 19.25 AVX2/AVX2) 1.2.0]
Bound  PAD: LilyPad.dll [LilyPad (20200506140834) 0.12.1]
Bound SPU2: Spu2-X.dll [SPU2-X 20200506140834 2.0.0]
Bound CDVD: cdvdGigaherz.dll [cdvdGigaherz 20200506140834 0.11.0]
Bound  USB: USBnull.dll [USBnull Driver 20200506140834 0.7.0]
Bound  FW: FWnull.dll [FWnull Driver 20200506140834 0.7.0]
Bound DEV9: DEV9null.dll [DEV9null Driver 20200506140834 0.5.0]
Plugins loaded successfully.

(GameDB) 9858 games on record (loaded in 437ms)
HLE Notice: ELF does not have a path.

Initializing plugins...
Init GS
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Patches: No CRC found, using 00000000 instead.
Opening plugins...
Opening GS
Error overriding KB shortcut for 'Sys_RecordingToggle': can't understand ''
Opening PAD
Opening SPU2
Current Renderer: Direct3D 11 (Hardware renderer)
Totally mismatched window handles on OverrideWndProc!
Totally mismatched window handles on OverrideWndProc!
Totally mismatched window handles on OverrideWndProc!
Opening CDVD
isoFile open ok: H:\Game\PS2\Sengoku Musou Moushouden.ISO
Image type  = DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (2286096 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0 [File]: C:\Users\aaa\Documents\PCSX2\memcards\Mcd001.ps2
GSdx Lookup CRC:0
McdSlot 1 [File]: C:\Users\aaa\Documents\PCSX2\memcards\Mcd002.ps2
GSdx Lookup CRC:0
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: Japan  v02.20(05/09/2006)  Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
# Initialize memory (rev:4.00, ctm:196Mhz, cpuclk:147Mhz detected)
Frame buffer size set to  512x1280 (2048x5120)

PlayStation 2 ======== Hard reset boot
ROMGEN=2006-0905, IOP info (CPUID=1f, CACH_CONFIG=14000200, 2MB, IOP mode)
<20060905-125923,ROMconf,PS20220WC20060905.bin:11824>
# Total accessable memory size: 32 MB (B:2:8:0) (400:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Sep  5 2006 12:57:08
  CPUID=2e20, BoardID=0, ROMGEN=2006-0905, 32M

Patches: No CRC found, using 00000000 instead.
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLPM_657.18;1
(SYSTEM.CNF) Software version = 1.03
(SYSTEM.CNF) Disc region type = NTSC
found 0 symbols
ELF (cdrom0:\SLPM_657.18;1) Game CRC = 0xDBD2230B, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLPM_657.18;1
(SYSTEM.CNF) Software version = 1.03
(SYSTEM.CNF) Disc region type = NTSC

IOP Realtime Kernel Ver.0.9.1
    Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname cdrom0:¥SLPM_657.18;1 secname all
loadelf version 3.30
Input ELF format filename = cdrom0:¥SLPM_657.18;1
0 00100000 00262700 .......................................
Loaded, cdrom0:¥SLPM_657.18;1
start address 0x100008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
Elf entry point @ 0x00100008 about to get recompiled. Load patches first.
Get Reboot Request From EE
GSdx Lookup CRC:DBD2230B
GSdx Lookup CRC:DBD2230B
ROM directory not found

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init

IOP Realtime Kernel Ver. 2.2
    Copyright 1999-2002 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadmodule: fname cdrom0:¥MODULES¥DEV9.IRX;1 args 0 arg
dev9: unknown dev9 hardware.
loadmodule: id 35, ret 1
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.93 fps
Frame buffer size set to  1024x1280 (4096x5120)
Stream Buffer 1Bank 32768byte 5banks 163840byte used
Stream Buffer 1Bank 32768byte 5banks 163840byte used
Stream Buffer 1Bank 32768byte 5banks 163840byte used
Closing plugins...
Closing DEV9
Closing FW
Closing USB
Closing CDVD
Closing SPU2
Closing PAD
Closing GS
Plugins closed successfully.
Shutting down plugins...
Plugins shutdown successfully.
(GameDB) Unloading...
Reply
#4
what are your gsdx settings ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
(06-18-2021, 10:08 PM)jesalvein Wrote: what are your gsdx settings ?

Screenshot shows the settings I'm currently using.

But, I've tried changing every setting here and nothing helped either..


Attached Files Thumbnail(s)
   
Reply
#6
it happens only when upscaling ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#7
(06-18-2021, 10:23 PM)jesalvein Wrote: it happens only when upscaling ?

Yes. If I press F9 to toggle to software mode,  or run the game in native resolution, there are no vertical lines.


Attached Files Thumbnail(s)
       
Reply
#8
Ok. An upscaling bug, then.
Dunno if it has been reported, but it probably will be on low priority.

Different things to try : half pixel offset, merge sprite,round sprite. But it's highly possible it's not fixable for now.

Try latest Dev build too
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#9
While I'm at it, there is a different issue I have to mention. We have to swap discs when playing Musou Warriors games but the we can't swap disc properly in the official builds.
Here, someone provided a test build and it worked, however that person has not been active on Github for a while now. I am not sure if the fix has been implemented in the master branch. Please check so we don't lose the ability to swap disc in the next official release.
Reply
#10
can't test since i don't have this game.
best is to try dev builds by yourself
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply




Users browsing this thread: 1 Guest(s)