Savestate problems with latest beta installer
Hi again! it's been a time since i could post something here (been very very busy)...

Ok, the thing is, we all know about xenosaga ep 1 problem with saves, so I should attempt a savestate before every save point. The thing is when I do a savestate everything's fine, but when trying to reload it, i can't, the emulator resets itself and I get the following message:

Error: Savestate data is corrupted or incomplete
Filename: Tag: MTGS

This happens with xenosaga or any other game..., no matter what slot I do save in...

Also my specs are at bottom (signature) and I'm using the latest beta installer (with plugins). GSdx, DX10HW, SSe4, CPU w/o MicroVU (slower if enabled), built-in iso loader or linuz (tried both), minimal speed hacks enabled..
SAGER NP8690 | i7-620M 2.66Ghz | 6GB RAM | ATI 5870M 1GB GDDR5 | FullHD 1080p 15.6'' | 500GB HDD 7200RPM | WINDOWS 7

Sponsored links

List all your plugins. Keep in mind you'll have to use the Lilypad that came with the latest beta plugins for consistent save states (SPU2-X is also recommended)
[Image: newsig.jpg]
I had the same problem.

The problem for me is that I cannot close the GSDX window and go to the GUI of PCSX2 to save (like File --> States --> Save)

HOWEVER, I can save my PCSX2 save states WHILE PCSX2 IS STILL RUNNING without corruption, and they will always load. This solution has worked for me on every version of PCSX2 since it had stopped working through the GUI for me way back when.

Press F1 to save a state, F2 to switch a state, and F3 to load a state during emulation (re: I don't press escape to save states, I use the shortcut keys during emulation).

Some other things you might be able to do are... run PCSX2 in Administrator mode (right click on shortcut, compatibility, tick 'run as administrator')... actually that's all I can think of lol.

Hope that helps, cheers.

Oh ya, one important thing:

MAKE SURE you have enough space on your hard disk for save states, otherwise save states will not work (they need to save somewhere right?).

From my experience each PCSX2 save state requires about 25 MB of disk space, so make sure you have enough space on whichever drive you are using to save when you are using the save state function.
Check out my snazzy Youtube channel, with many great PCSX2 emulation videos! Laugh Laugh
Think about what you are doing. By doing a save-state before a memcard save, then a save writes to the memcard, if you then load that save-state you are now at a point where the emulator is running before it wrote that save, yet the memcard now contains a save that shouldn't be there so it becomes corrupt.
If I read that right, just re-reading what you posted.

Couldn't you export the save with Memcard Manager, format a second memcard and import the save to that card, load your sate then exit to the menu and load in a second memcard to mem slot 2, depending on if the game supports 2 memcards for slot 1 and slot 2.
Intel E7500 @ 4.00ghz 400 fsb / Asus P5QL Pro / 4Gb Kingston RAM / PNY nvidia 9800GT 512Mb / Creative X-Fi Music 24 / Vista 64 SP2/
DKTronics, savestates are totally independent from a memcard save. You can save a state no matter where in the game and it doesn't alter anyting in your memcard. On the real PS2 in a real game (not emulator/ISO), you can even take out your memcard, insert a new one, and save there. The game doesn't hang or corrupt anything.

Curryking, that was the problem!! i just came back here to tell that I found a way to and just your answer was there haha! I don't know why, but in-game i can save states, but via GUI, it gets corrupted =P thanks anyway pal!!! finally! hehe.

Oh bositman, I am using the plugins that came with the installer, haven't changed any of them, just changed the configuration.

Thanks everybody!! you migh close this thread =P
SAGER NP8690 | i7-620M 2.66Ghz | 6GB RAM | ATI 5870M 1GB GDDR5 | FullHD 1080p 15.6'' | 500GB HDD 7200RPM | WINDOWS 7
Yeah I've never went back to the GUI and save state that's why I keep forgetting that never worked properly Tongue
An issue already solved in the new GUI Wink
[Image: newsig.jpg]

Users browsing this thread: 1 Guest(s)