Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sc3 crash
#1
Hi again.

Ever since updating the emulator SoulCalibur 3 keeps crashing randomly O.O (if you play survival, it can be as far as 20th match or as close as 5th - the game goes into loading screen and freezes.)

Is there something to be done that I should try, please?
Reply

Sponsored links

#2
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Reply
#3
Hello.

I'm having the same issue as OP. Thought of looking before opening a new topic.

Essentially as described, SCIII freezes at the 'Now Loading' screen. Music continues to play but it just stays there, with a black screen.

I first came into this while playing Survival on Medium. I tried three times but that always happened, twice around round 10-15, another at round 21 or 22. So I gave up. Now this has been happening a lot in Chronicles of the Sword mode, when I have to fight more than 2 characters in a row.

I believe this is the code that regards the bug. After that, I simply paused and shut down:

Code:
48000 SampleRate:
WARNING : Reset PC0
WARNING : Reset PC0
WARNING : Reset PC0


Any help would be much appreciated.
Reply
#4
(02-27-2021, 05:51 PM)BBVenom Wrote: Hi again.

Ever since updating the emulator SoulCalibur 3 keeps crashing randomly O.O (if you play survival, it can be as far as 20th match or as close as 5th - the game goes into loading screen and freezes.)

Is there something to be done that I should try, please?

(05-12-2021, 02:40 AM)RFC Wrote: Hello.

I'm having the same issue as OP. Thought of looking before opening a new topic.

Essentially as described, SCIII freezes at the 'Now Loading' screen. Music continues to play but it just stays there, with a black screen.

I first came into this while playing Survival on Medium. I tried three times but that always happened, twice around round 10-15, another at round 21 or 22. So I gave up. Now this has been happening a lot in Chronicles of the Sword mode, when I have to fight more than 2 characters in a row.

I believe this is the code that regards the bug. After that, I simply paused and shut down:

Code:
48000 SampleRate:
WARNING : Reset PC0
WARNING : Reset PC0
WARNING : Reset PC0


Any help would be much appreciated.

What version of pcsx2 you're running that have this problem with SC3 ? Go back to the version that run SC3 without problems.
OS: Windows 10 Home 64 BIT 20H2
CPU: AMD R7-3700X 3.6 GHZ
GPU: Asus GeForce GTX 1650 Super
RAM: Corsair   LPX 3200MHZ 32GB DDR4 
Mainboard: Gigabyte B450 PRO WIFI
Display: Asus VP228
Audio: Creative Sound Blaster Z / GigaWorks T40
Storage: Seagate 1TB HDD, Transcend 1TB SSD
Optical: Asus BW-16D1HT Blu-Ray Writer
Power supply: Corsair CX550M
Reply
#5
for 1.6.0 try use Directsound
for 1.7.0 try use PortAudio
Main PC1:i5-4670,HD7770(Active!)
Main PC2:i5-11600K,GTX1660Ti(Active!)
PCSX2 Discord server IGN:smartstrike
PCSX2 version uses:Custom compiled build 1.7.0 64-bit(to be update regularly)
smartstk's YouTube Channel
Reply
#6
As far as I can tell, I never had a version running without the issue. I believe the software updated recently, but I'm not sure that had anything to do, can't say whether that was before or after I first ran into the problem. As mentioned, it only became apparent while playing modes with several battles in a row, like Survival or later Chronicles of the Sword.

Thank you both for your advice.

Version is 1.7.0 now, so I'll try changing to PortAudio and see if that makes any difference.
Reply
#7
Unfortunately changing to PortAudio didn't fix it.

At first I thought it had since I was able to fight +5 foes in a row at Chronicles, but the game froze again when I tried Survival.

Thanks for the suggestions anyway.

I'll try reverting to a previous PCSX2 version and see if that solves it.
Reply
#8
Could you please post the full emulog
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Reply
#9
I can't. I've now removed the PCSX2 1.7.0 build completely. But I had checked the log after the last crash and it was the same as before:

Code:
WARNING : Reset PC0


I can also confirm that reverting to version 1.6.0 fixes the issue altogether.
Reply
#10
ok.
good for you, then
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Reply




Users browsing this thread: 1 Guest(s)