Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Scarface graphical issues (PAL)
#1
Exclamation 
So I understand this game is a kicker if its not played in software mode, but I'd love to get to the bottom of the issues and get it working.

Purchased my game at CEX, tried running off disc and created an iso as well but still have the issues.

AMD FX-8320 OC to 4Ghz
NVIDIA GTX 750Ti 2GB
16GB 1600mhz DDR3
Windows 10

pcsx2-v1.5.0-dev-2212-g96b412ebb-windows-x86

PCSX2 1.5.0-20171029010149 - compiled on Oct 29 2017
Savestate version: 0x9a0d0000

Host Machine Init:
Operating System =  Microsoft Windows 10 Home (build 16299), 64-bit
Physical RAM     =  16356 MB
CPU name         =  AMD FX™-8320 Eight-Core Processor
Vendor/Model     =  AuthenticAMD (stepping 00)
CPU speed        =  4.027 ghz (8 logical threads)
x86PType         =  Standard OEM
x86Flags         =  178bfbff 3e98320b
x86EFlags        =  2fd3fbff

x86 Features Detected:
SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. FMA
SSE4a

Reserving memory for recompilers...

Loading plugins from C:\Users\steve\Documents\pcsx2-v1.5.0-dev-2212-g96b412ebb-windows-x86\plugins...
(GameDB) 9712 games on record (loaded in 275ms)
Bound   GS: GSdx32-SSE4.dll [GSdx 20171029010149 (MSVC 19.00 SSE4.1/AVX) 1.1.0]
Bound  PAD: LilyPad.dll [LilyPad (20171029010149) 0.12.1]
Bound SPU2: Spu2-X.dll [SPU2-X 20171029010149 2.0.0]
Bound CDVD: cdvdGigaherz.dll [cdvdGigaherz 20171029010149 0.11.0]
Bound  USB: USBnull.dll [USBnull Driver 20171029010149 0.7.0]
Bound   FW: FWnull.dll [FWnull Driver 20171029010149 0.7.0]
Bound DEV9: DEV9null.dll [DEV9null Driver 20171029010149 0.5.0]
Plugins loaded successfully.

I've attached some images showing my video settings.
I've tested all options on those screens, turning them on and off.
The settings I have offer the most "playable" experience. Skipdraw 3 gets rid of the horrible green texture but some other renders are missing, and everything is still purple.
Scarfare I-Bit hack is enabled.

Would love to know if there is anything else I could try out.


Attached Files Thumbnail(s)
           
Reply

Sponsored links

#2
Just done some further testing.

In Game fixes, I have gone through all fixes visible.
The only setting to have an effect is Delay VIF1 Stalls, which messes up the visuals even more.

In the VUs menu, setting VU1 to Interpreter messes up the graphics, as does VU0/VU1 recompiler mode being set to Negative.

Other settings appear to have no visible effect.

Disabled all speedhacks and no visible effect was produced.


Attached Files Thumbnail(s)
           
Reply
#3
(11-06-2017, 01:04 AM)lemondrizzle Wrote: Just done some further testing.

In Game fixes, I have gone through all fixes visible.
The only setting to have an effect is Delay VIF1 Stalls, which messes up the visuals even more.

In the VUs menu, setting VU1 to Interpreter messes up the graphics, as does VU0/VU1 recompiler mode being set to Negative.

Other settings appear to have no visible effect.

Disabled all speedhacks and no visible effect was produced.

Do you have automatic gamefixes enabled? That's all you should need.
Reply
#4
(11-06-2017, 02:02 AM)CK1 Wrote: Do you have automatic gamefixes enabled? That's all you should need.

Naturally Smile


Attached Files Thumbnail(s)
   
Reply
#5
Would any information from the debugger be useful?

I can't interpret it myself Sad
Reply
#6
I've made a GS dump, here the link: https://mega.nz/#!MC512B7K!0kERmVwSgCde2...3bgSB4FvmE

Don't know if anyone can interpret this.

I turned off the skipdraw for this dump.
Reply
#7
The dump doesn't work for me for some reason. Can you try again a single frame ?
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply
#8
(11-08-2017, 10:14 PM)lightningterror Wrote: The dump doesn't work for me for some reason. Can you try again a single frame ?

It's compressed to .7z, maybe that's the issue? I know single frames compress to .xz


I've attached the single frame dumps.

Just of note, if I set skipdraw to a negative value, all the graphical glitches go away and the colours are right, but it removes most other sprites.
I've attached these too for you, see if it helps troubleshooting.


Attached Files Thumbnail(s)
       

.xz   gsdx_20171108202709.gs.xz (Size: 848,37 KB / Downloads: 149)
.xz   gsdx_20171108202957.gs (-1 skipdraw).xz (Size: 995,74 KB / Downloads: 99)
Reply




Users browsing this thread: 1 Guest(s)