Thread Rating:
  • 16 Vote(s) - 4.88 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ScpToolkit (XInput Wrapper aka ScpServer Reloaded)
#1
Update 1/26/2018 - SCPToolkit is no longer in development at this time. You can still download the final stable build in the URL below.

Greetings fellow gamers!

Long story short: this thread continues the work of the mighty yet vanished Scarlet.Crush´s Xinput Wrapper aka ScpServer aka "make my DualShock Controller work with Windows games!"

Follow the developer on Twitter to stay updated!

→ Project repository
The project is 100% free open-source software, developers and interested users may review, build or extend the code base on their own anytime. The link takes you to the project's GitHub page.

→ Installation requirements
To ensure the installation and usage of the software succeeds it's mandatory to ensure all requirements listed here are met.

→ Installation How-To
The installation is straight-forward; the few steps required for a successful setup are described here.

→ Download latest stable release here ←
Obtain the latest build here; the free tool 7-Zip is required to extract the archive.
Reply

Sponsored links

#2
Took your time to open your own thread  Happy
Reply
#3
(08-09-2015, 03:23 PM)K.F Wrote: Took your time to open your own thread  Happy

I probably thought about some introducing lines longer than necessary Biggrin
Reply
#4
Woohoo, a new thread!

Testing new version and I've run into few issues.

1) ScpServer can't start the service, is says "The root hub is already running, please close the ScpServer first!", I don't know if that is a bug or a feature Smile.

2) My non genuine (PLAYSTATION®3Conteroller-PANHAI) controller is not working in Bluetooth mode. When I turn controller on, it tries to connect, but crashes and I have to do hard reset of the controller. I've tried to add its MAC address to the ScpControl.ini into [BthDs3] section, but that hasn't helped. Genuine controller works without problem.
Dongle USB\VID_0A12&PID_0001&REV_7558
Log file: https://www.sendspace.com/file/qwqoej


3) My another dongle is not working with any controller at all. Genuine controller connects without problems, gets its number, but doesn't work. In SCP Monitor I can see the controller connected, but instead of battery, it shows Pad 1 : MAC Address - BTH 00000000 None.
Dongle: USB\VID_0A12&PID_0001&REV_0134
Log file: https://www.sendspace.com/file/lqbfl7
Reply
#5
(08-09-2015, 05:57 PM)Reebar Wrote: 1) ScpServer can't start the service, is says "The root hub is already running, please close the ScpServer first!", I don't know if that is a bug or a feature Smile.

You must start either the Windows Service or the stand-alone executable but not both since they perform the same job.
Reply
#6
Still getting the same issue I reported in the last thread, DS4+Bluetooth is not working on windows 10. This time there are no errors reported, it just disconnects immediately after acquiring a connection.


Attached Files
.xml   ScpDsxServer.log.xml (Size: 74,11 KB / Downloads: 5.759)
Reply
#7
(08-09-2015, 07:58 PM)Darkimmortal Wrote: Still getting the same issue I reported in the last thread, DS4+Bluetooth is not working on windows 10. This time there are no errors reported, it just disconnects immediately after acquiring a connection.

Hardware-IDs? Tongue
Reply
#8
(08-09-2015, 09:05 PM)Nefarius Wrote: Hardware-IDs? Tongue

Bluetooth adapter: USB\VID_0A12&PID_0001
DS4: USB\VID_054C&PID_05C4
Reply
#9
Reply from the previous thread

Hi Nefarius,

I just downloaded the latest from GitHub, uninstalled then deleted all the old files, then unpacked and installed the latest. But I still get BTH 00000000 None after unplugged my controller. I did look through the ScpControl.ini file and found my hardware ID in there, so is there anything else you would want me to try? Maybe I need a different adapter?

Thanks!
Reply
#10
Nefarius - You were giving me some awesome help over in the old thread, but I still seem to have the lingering issue of my flashed bluetooth drivers getting overwritten (likely by Windows) after a few days of use. I'm on Windows 8.1, 64 bit.

Bluetooth Hardware IDs:
USB\VID_0A5C&PID_21E8&REV_0112
USB\VID_0A5C&PID_21E8

PS3 Controller Hardware IDs:
USB\VID_045E&PID_028E&REV_0114
USB\VID_045E&PID_028E
(It is also showing up as an 'Xbox 360 Controller for Windows)

I had initially talked about my issue here:
http://forums.pcsx2.net/Thread-XInput-Wr...#pid472450


Unfortunately, I already changed the settings detailed here:
http://www.tomshardware.co.uk/faq/id-216...icons.html

And the problem is still persisting. Any other ideas? My last attempt was with your v1.3.5689.40377
Reply




Users browsing this thread: 16 Guest(s)