Thread Rating:
  • 16 Vote(s) - 4.88 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ScpToolkit (XInput Wrapper aka ScpServer Reloaded)
Cause this release is not really supported (no updates) and new versions of similar tool are for win 10 only, i guess i can post it here?

I just tested this (not sure if beta client needed, but i use beta just in case, care to double check every mapping for buttons, cause sometimes it say axis x and after second press - button x. Working is last one). And it's perfectly working solution without need for any tool besides ps now app (you only need driver from there actually). Some games even show ps layout to you as some good addition. I guess it would be helpfull, all credit goes to author of the guide, he is the hero, not me (even if i asked on steam forums for more controller, specifically ds3 support).

p.s. Maybe gyro is too sensitive or idk. But it doesn't matter if all working good, right?

Small update: after more testing... it's good but only works for some games. So it's only the temporary solution sadly.

Sponsored links

When I right click on the icon in the tray, the profile manager is missing. I can only test the buttons, which work famously, or reset position. Halp! thank you Tongue
I need help, I'm trying to install this driver but it says its not connected. Here is the gamepad analyzer dump.

Attached Files
.txt   Pro Ex mini for PS3_hid-report.dump.txt (Size: 3,57 KB / Downloads: 54)
Hello, I have an error message. I don't know why but it keeps returning every 10 seconds. Can someone help me make it go away? Bottom right.
Hi, Sorry but I already search alot, but it seems like I cannot find the answer anywhere.
Im using Ps3 controller. I install this tool step by step exactly like the guide 1st page told me. Everything went smooth. If I open ScpToolkit monitor, I got a "server connected message . The window gave me this line: "Host address: disconnected. Pad one: DS3 60.38....etc usb ...charging". I can test the pad using the "input tester" function alright.

But what do i do next? When go into pcsx2 using lily pad plugin I cannot configure any button (ofc if I open the game, the pad wont work). I even copied the lilypad scp from the scp folder and use that plug in, still no work. Is there any extra step am I supposed to do?
I recently did a clean install of windows 8.1 on my system, installed the newest version of SCP, and I'm getting this weird bug wherein every few seconds the joysticks are seen as being flicked to the top left several times. Additionally, when I plug in my VERY REAL PS3 controller, I get the error "fake Dualshock 3 detected".
Could somebody please help me out? I need to swap L2/L3 and R2/R3. From what I understand this was possible in the old profile manager but the current manager is broken so is there any way to do this now?
Wondering if anyone has had this happen. I had my DS3 controller working fine. I then changed some setting and deleted SCP because I wasn't using it. I wanted to play some ps2 games again and reinstalled scp and plugged in the controller again and it synced fine. But for some reason now it does not sync. I have it plugged in via usb and I do the driver install for the Dualshock 3 controller. I have the Xbox 360 accessories stuff installed. I install the drivers and nothing. When I plug in the controller and I have the SCP server (legacy) window open it say "Arrival" for the controller but I get no notification from SCP and the controller never syncs. Any ideas?
Wanted to notice, that with todays Microsoft Windows 10 Creators Update (Build 15063) the SCP Toolkit stopped working.
So previously I have a Sixaxis (which scptoolkit sees as a fake Dualshock 3 for some reason) working fine via both USB and Bluetooth but it has recently developed a mechanical problem (left stick likes to cause items to move right on there own) so I am trying to use another of the exact same model CECHCZ2U A1. This new one connects fine with USB but won't connect with Bluetooth. I just keep getting "Fake Dualshock 3 found. Trying workarounds..." over and over. Tried many solutions including pushing that tiny button inside with a paper clip (which is how I got the previous one to work) with no luck. Any help would be appreciated. I'm not keen on being connected with a wire constantly. Would rather use the wire only to let it charge when not being used to play a game.

Users browsing this thread: 25 Guest(s)