Thread Rating:
  • 16 Vote(s) - 4.88 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ScpToolkit (XInput Wrapper aka ScpServer Reloaded)
(02-11-2018, 01:07 AM)Triat Wrote: Hey everyone! I've been using Nefarius's ScpToolkit for my 2 DS3s, 1 DS4 setup and it works great, never had a problem.

Unfortunately, I bought a second DS4 without realizing they were a new version which ScpToolkit does not support. The new ones apparently do not require these programs.
The problem is when I try to use the old DS4(v1) with Scp at the same time. It's total chaos ingame. So does anyone have any suggestions for 2 DS3's and DS4v1 + DS4v2? Or could I leave a good word for Nefarius to maybe implement something like this in his future projects? OSmile

Cheers!

Not sure if this is the best way to solve this, but it worked for me. Try using an older version, v1.6.238.16010. This way you can select and use the "Force Install" option.

Sponsored links

I cannot seem to get it connected via Bluetooth no matter what I try. I have all the drivers installed (I had to add it to the ini file then boot with driver signature enforcement off). The host address shows up, but the controller still says disconnected. It's a fake controller, and no I have no other option at this point. It is almost unusable with cable because it is so short and I also would like to use my extra USB port for other things.

Windows 7 x64

The ScpPair tool just shows up blank:
[Image: bgR5O7y7TK6LrmS6cV9pSg.png]
Help plz. I followed the steps but have a problem getting my controller to work, it's plugged in but all it does is vibrate... :'(
It's a ps3 usb controller.

I'm kinda like very new to this stuff. I wanted to see if controller was easier for me but am lost as to what to do next
(03-01-2018, 01:14 AM)sbr10251 Wrote: Help plz. I followed the steps but have a problem getting my controller to work, it's plugged in but all it does is vibrate... :'(
It's a ps3 usb controller.

I'm kinda like very new to this stuff. I wanted to see if controller was easier for me but am lost as to what to do next

Sounds like a fake controller. What shows up in "Devices and Printers?"
(08-06-2016, 10:41 PM)snakepl Wrote: **Update**
This problem only happens when I use the latest Xinput1_3.dll from the beta build.
When I use the Xinput1_3.dll from the stable build everything works fine.
**

Hi, I'm having problems with the latest ScpToolkit v1.7.277.16103-BETA and pcsx2 1.4.0.
The DS3 native mode doesn't work and this is what shows up multiple times in the Xinput log file (XInput1_3_Username.log.xml):

<log4j:event logger="ScpXInputBridge.XInputDll" timestamp="1470515308832" level="ERROR" thread="1"><log4j:message>Couldn't receive pressure information: Microsoft.CSharp.RuntimeBinder.RuntimeBinderInternalCompilerException: An unexpected exception occurred while binding a dynamic operation
  at Microsoft.CSharp.RuntimeBinder.RuntimeBinder.Bind(DynamicMetaObjectBinder payload, IEnumerable`1 parameters, DynamicMetaObject[] args, DynamicMetaObject&amp; deferredBinding)
  at Microsoft.CSharp.RuntimeBinder.BinderHelper.Bind(DynamicMetaObjectBinder action, RuntimeBinder binder, IEnumerable`1 args, IEnumerable`1 arginfos, DynamicMetaObject onBindingError)
  at Microsoft.CSharp.RuntimeBinder.CSharpConvertBinder.FallbackConvert(DynamicMetaObject target, DynamicMetaObject errorSuggestion)
  at System.Dynamic.DynamicMetaObject.BindConvert(ConvertBinder binder)
  at System.Dynamic.ConvertBinder.Bind(DynamicMetaObject target, DynamicMetaObject[] args)
  at System.Dynamic.DynamicMetaObjectBinder.Bind(Object[] args, ReadOnlyCollection`1 parameters, LabelTarget returnLabel)
  at System.Runtime.CompilerServices.CallSiteBinder.BindCore[T](CallSite`1 site, Object[] args)
  at System.Dynamic.UpdateDelegates.UpdateAndExecute1[T0,TRet](CallSite site, T0 arg0)
  at ScpXInputBridge.XInputDll.XInputGetExtended(UInt32 dwUserIndex, SCP_EXTN&amp; pPressure)</log4j:message><log4jTongue2roperties><log4j:data name="log4jmachinename" value="Awesome8" /><log4j:data name="log4japp" value="DefaultDomain" /><log4j:data name="log4net:Identity" value="" /><log4j:data name="log4net:UserName" value="Awesome8\Vic" /><log4j:data name="log4net:HostName" value="Awesome8" /></log4jTongue2roperties><log4j:locationInfo class="ScpXInputBridge.XInputDll" method="XInputGetExtended" file="" line="0" /></log4j:event>


Also take a look at the screenshot. Testing the DS3 in native mode in PCSX2 gives random values and it doesn't respond to any inputs from the controller.
I think something is up with the latest Xinput dll file. I have tried reinstalling the toolkit, PCSX2, and VC redist with no effect.

BTW, running Windows 8.1 x64.

I want to thank you, as your post is the only one I found on the entire internet about this issue, let alone an update/solution. I've used the beta build since I started emulating on PCSX2, and this error popped up seemingly overnight.

Same beta version, same errors filling the entire screen (literally), switching to the stable build cleaned all errors right up. Many thanks.
Hi guys,
I installed the software but am not able to use the controller. Seems like no button is working, anyway Windows shows the controller as "OK".

When I open the Monitor it shows the controller as reserved but the adress is all zero...

Can somebody help?

Here a schreenshot of the monitor:
https://mega.nz/#!a7ATmYDK!nU-ejXU6savMm...ROoyJHcAtA

You need Log files?
Hello guys, i hope you can help me with something, see i've got the latest version of SCPtoolkit, the beta one, it works perfectly with well..my fake dualshock 3 controller when is used like a plug and play device but when i try to use the bluetooth, it doesn't pair and i'll get the following error. (pic)

I've been looking for solutions and i found thales "solution" on github, followed all the steps and replaced the SCPcontroller DLL but it still gives me the same error..You guys know another solution or something?

Please and thank you in advance.


Attached Files Thumbnail(s)
   
It seems when I press certain key combinations it gets "stuck" and I have to unplug the controller and plug it back in for it to work properly again. This is not ideal for playing some games as I basically NEED these key combinations.
connecting ps3 remote


Attached Files
.txt   PLAYSTATION(R)3 Controller_hid-report.dump.txt (Size: 88 bytes / Downloads: 93)
I now have an issue where it randomly stops taking input and I have to disconnect the controller and reconnect it. It is extremely aggravating and makes everything unplayable as every minute or so it happens.




Users browsing this thread: 7 Guest(s)