Thread Rating:
  • 16 Vote(s) - 4.88 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ScpToolkit (XInput Wrapper aka ScpServer Reloaded)
(09-22-2015, 07:52 AM)WkNaZA9 Wrote: Hi,
Let's see if someone is able to help me.

My controller works perfectly with SCP, however it only works the first time I install the drivers. If I reboot or put the computer to sleep, the controller doesn't work anymore. If I uninstall and reinstall the driver, it works again until the next reboot.

Any clue on what is going on? Maybe the driver fails to initialize on boot? or the dongle is not fully supported?

My DS3 controller is supposed to be supported, I have this one:
HID\VID_054C&PID_0268&REV_0100   (by the way, the controller is from Sony, not Bigben, don't know why scp detects it as fake controller)

The bluetooth dongle seems to work fine also until reboot. I have this one (integrated):
USB\VID_8087&PID_07DC&REV_0001

My OS is Win 10 x64

Any help would be truly appreciated Smile

Thanks!
hi, I'm attaching the logs, hope that helps to troubleshoot.

what I did:
-install scp service+drivers
-disconnect ds3 from usb
-connect ds3 via bluetooth (working fine here)
-rebooted
-try to connect ds3 via bluetooth (ds3 not connecting anymore)

thanks!


Attached Files
.7z   logs.7z (Size: 5,85 KB / Downloads: 70)

Sponsored links

(09-22-2015, 08:23 AM)WkNaZA9 Wrote: hi, I'm attaching the logs, hope that helps to troubleshoot.

what I did:
-install scp service+drivers
-disconnect ds3 from usb
-connect ds3 via bluetooth (working fine here)
-rebooted
-try to connect ds3 via bluetooth (ds3 not connecting anymore)

thanks!

Thank you, I think I found the error, give me some time to fix it Biggrin
(09-22-2015, 08:30 AM)Nefarius Wrote: Thank you, I think I found the error, give me some time to fix it Biggrin

Cool! Thanks a lot for looking into it! If you need other info or testing something on my side, let me know!
(09-22-2015, 06:32 AM)QuadStick Wrote: Thank you for including the QuadStick. 

I finally was able to test the 1.5.5740.18577 release and the QuadStick installed and ran OK on 64-bit Windows 8.1.  I also tried it on a 32-bit Windows 7 VM and got a WDI_ERROR_NOT_FOUND error message.  Logs attached.

Btw. does the QuadStick have Rumble support? Or controllable LEDs?
(09-22-2015, 08:11 AM)Nefarius Wrote: You can help me test the attached BETA release containing attempts to support those. Tests and feedback from other PANHAI users greatly appreciated!

I will installed beta version and usb works fine, bluetooth too work, but when connected all the time flashing all LEDs and vibration not work. Added logs


Attached Files
.xml   ScpDsxInstaller_DANTE.log.xml (Size: 22,11 KB / Downloads: 321)
.xml   ScpDsxService_DANTE-PC$.log.xml (Size: 85,05 KB / Downloads: 396)
(09-21-2015, 10:26 PM)spartaofdoom Wrote: http://www.xup.in/dl,14900876/ScpDsxInstaller.log.xml/, http://www.xup.in/dl,18459120/ScpDsxService.log.xml/ here they are its not a problem that is on the original post. Thanks my little 1337h4x0r.

See, that's why Logs are so important; your installation Log is overflowing with errors; first of all please open an elevated command prompt and execute the following line:

Code:
sc delete Ds3Service

Reboot. Then extract the latest release to a new directory on e.g. you C:\ drive. Plug in all the Controllers you wanna use via USB and the Bluetooth dongle to your machine. After their Windows drivers have been installed automatically run ScpDriver. You should be prompted to allow administrative rights. Accept that. Leave the default check boxes and hit Install.
(09-22-2015, 08:59 AM)DANTE1613 Wrote: I will installed beta version and usb works fine, bluetooth too work, but when connected all the time flashing all LEDs and vibration not work. Added logs

Please try this new DLL, just overwrite the existing one, no need to run the installer again, just restart the service and try again. Submit the Logs again after that, thanks!


Attached Files
.7z   ScpControl_v1.5.5743.14957.7z (Size: 60,79 KB / Downloads: 119)
Replaced, but the same still flashing all LEDs, vibration not work over bluetooth


Attached Files
.xml   ScpDsxInstaller_DANTE.log.xml (Size: 22,11 KB / Downloads: 222)
.xml   ScpDsxService_DANTE-PC$.log.xml (Size: 261,67 KB / Downloads: 353)
(09-22-2015, 08:11 AM)Nefarius Wrote: You can help me test the attached BETA release containing attempts to support those. Tests and feedback from other PANHAI users greatly appreciated!
I tested it multiple times. 
one thing I have notices all the way back from version 1.2.2.175 is that no matter how many times I pair the controller, when I connect it back, it shows the MAC as Remote [00:00:00:00:00:00].


Attached Files
.zip   logs.zip (Size: 11,97 KB / Downloads: 63)
By the way flashing LEDs only when connected over bluetooth, usb works normally




Users browsing this thread: 5 Guest(s)