Thread Rating:
  • 16 Vote(s) - 4.88 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ScpToolkit (XInput Wrapper aka ScpServer Reloaded)
#51
(08-12-2015, 01:51 PM)crimsonsmoke Wrote: Hi Nefarious, thank you for taking this over.

So I've just upgraded from a Windows 7 64 install to Windows 10. 

My wired ps3 controller worked seamlessly in windows 7 following this guide: https://www.youtube.com/watch?v=TpSaOJJIun8

After the Windows 10 upgrade it has since stopped working - I uninstalled the old Scp drivers and reinstalled yours. 

Now, when I connect my PS3 controller to my PC via USB all four lights on the back flash continuously for a while and then go blank - the controller registers as attached hardware and in the Scp monitor program it says:

Host Address: 00:00:00:00:00:00     Pad 1   :   DS3 00:00:00:00:00:00    -    USB FFFFFFFF Charging


In Device Manager my device ids for the PS3 controller are: 
       USB\VID_054C&PID_0268&REV_0100
       USB\VID_054C&PID_0268

The Scp Virtual Bus Driver is also visible and working under system devices too.

It is also worth noting that, for some reason, no Xbox 360 controller is visible in Devices and Printers; nor is there a 360 controller driver available in Device Manager. I have tried reinstalling xbox 360 drivers (for Windows 7) but every time it tells me the driver is installed...

I have attached the ScpDsxInstaller.log.xml file and a picture of my Devices and Printers window.

I'd really appreciate some help with this - many thanks in advance!

Looks like the default drivers for your DS3 haven't been installed correctly, it should show up in the recognized devices section like so:

[Image: 12-08-_2015_19-53-17.png]

Sponsored links

#52
(08-12-2015, 07:57 PM)Nefarius Wrote: Looks like the default drivers for your DS3 haven't been installed correctly, it should show up in the recognized devices section like so:

[Image: 12-08-_2015_19-53-17.png]

Thanks for your speedy reply - sorry to sound like a complete n00b but how do I force the ds3 drivers to install? 

Whenever I plug my ds3 in it doesn't auto install. Anyway to manually do it? Thanks!
#53
(08-12-2015, 08:54 PM)crimsonsmoke Wrote: Thanks for your speedy reply - sorry to sound like a complete n00b but how do I force the ds3 drivers to install? 

Whenever I plug my ds3 in it doesn't auto install. Anyway to manually do it? Thanks!

Look in the Windows Device Manager if it's listed under "Unknown devices" and try to update the driver there via Windows Update. There are plenty of tutorials out there so I won't repeat this Tongue
#54
Okay last update for tonight! This might be interesting for the Windows 7 users who might have had problems with the driver installer on previous versions. Gn8!
#55
(08-12-2015, 01:12 PM)JohnLoyd1 Wrote: If your dongle wasnt compatible, then you could have just manually input its Hardware ID and made it work that way.... And ScpService cannot be isntalled manually from trying to run the program it must be installed via elevated command prompt. 1.4.x isnt a bad build because its brand new nefarius makes sure it works before releasing it.

My dongle has two hardware IDs listed in the properties, one was found in the ScpControl.ini already and the other just had &REV001 at the end so I added that as well but I still don't get a working dongle. Just BTH 00000000 None.
#56
(08-12-2015, 09:55 PM)Nefarius Wrote: Okay last update for tonight! This might be interesting for the Windows 7 users who might have had problems with the driver installer on previous versions. Gn8!

After trying this latest update I am getting host address : <error>. Previous version before that my host address was all 0s.


Edit: After trying to uninstall again using ScpDriver, I was still stuck with SCP BTH device for my adapter. I tried uninstalling through device manager and selecting delete drivers but still they reinstalled as the Scp device. Eventually the right drivers installed (beyond generic which it was doing before). Now I have my host address back.

Looking more closely in ScpControl.ini, the DS3 Mac Address supported are 00:24:5C and 00:26:5C, but my controller MAC begins with 00:26:43. Is that why I can't connect? Is it possible to add the ability to since it's an actual DS3?

Edit again: I don't know what happened but I was playing a game for a bit and when I unplugged my controller to be done for the night it connected to bluetooth. I am just going to assume Nefarius is a genius.
#57
So the latest versions all work for me (and I no longer need Zadig to get the initial bluetooth firmware flashed). Awesome job there, Nefarius.

However, I'm still having my problem of Windows 8.1, 64 bit overwriting the bluetooth driver after a couple days. At that point, I either need to re-do it with ScpDriver, or use Zadig (saved from an old scp version) to get the firmware fixed again.

Again, I've already set the Windows settings to not automatically choose the firmware settings. Any other ideas?
#58
(08-12-2015, 09:55 PM)Nefarius Wrote: Okay last update for tonight! This might be interesting for the Windows 7 users who might have had problems with the driver installer on previous versions. Gn8!
getting an error running SCP server "root hub is already running" unless i close the scpservice.exe in the task manager.
USB works again, however bluetooth still doesn't work.

Cirago BTA6310
USB\VID_0A12&PID_0001&REV_5276
USB\VID_0A12&PID_0001


shows in the device config as BTH DS3 Device


Attached Files
.xml   ScpDsxInstaller.log.xml (Size: 20,92 KB / Downloads: 323)
.xml   ScpDsxServer.log.xml (Size: 57,61 KB / Downloads: 313)
.xml   ScpDsxService.log.xml (Size: 93,46 KB / Downloads: 311)
Intel Core i7-8700k @5ghz
G.Skill 16GB DDR4 @3600mhz
GeForce GTX 1080 8GB
Windows 10 x64
#59
Hi Nefarius, thank-you so much for updating the drivers... I used to use motioninjoy for awhile but when I upgraded to Windows 10, I decided to stay away from that program and try SCP. I installed the driver and it works great (I stick with wired, I don't have a BT dongle) but I was wondering though, does SCP have the ability to remap controls like DS3 does? I have a physical disability and the R2/L2 buttons are difficult for me to use so I like to remap those to R3/L3 for certain games. Thanks
#60
just installed newest build. After reboot still no success with the service starting. It still has no dependency. After Installation it tells me all 4 things installed but during installation the Pnp still fails as well as starting the service.


Attached Files
.xml   ScpDsxInstaller.log.xml (Size: 23,77 KB / Downloads: 361)




Users browsing this thread: 5 Guest(s)