Thread Rating:
  • 16 Vote(s) - 4.88 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ScpToolkit (XInput Wrapper aka ScpServer Reloaded)
I'm using the lastest stable release. Everything is working except connecting the controller via bluetooth.
https://i.imgur.com/gEwuwvS.png
In the scpMonitor, after I uplugged the controller, the status changed to Reserved. I saw online videos and the controller would immediately switch to bluetooth mode.

My bluetooth dongle is supported, and when I plug in the dongle, the bottom-right notifications say it's compatible with DS3 and DS4 controller.
Reply

Sponsored links

Hello Everyone.
After I finished installing SCP Driver package for my DS3 Controller in Windows 10 64 bit, everything seem fine at first, every button work properly except both Left and Right Analog Sticks that keep pointing in upper left direction and won't move an inch. Much appreciate if Anybody know to fix this.

This is screenshot from Properties menu, every button work except analog sticks.
https://i.imgur.com/dT38kUz.png

This is screenshot from SCPUser, notice the value in red circle? It won't change not matter what I did.
https://i.imgur.com/kos1u97.png
Reply
Hi,

I formatted my SSD and installed windows 7 64, when I click the share and home button to connect Bluetooth I get this:

https://imgur.com/a/eFRG5

This didn't happen before formatted.

Thanks
Reply
Would installing this conflict with DS4Windows? I only need the DS3 for Metal Gear Solid and The Bouncer since those are the three games that depend most on the analog face buttons, and I'd rather not butcher the DS4Windows install since I use it for keyboard remaps and whatnot.
Reply
I've been using this for a while with a DS3 and DS4 controller over bluetooth and it has been working great. However, I just bought a new DS4 controller and it does not show up in the driver installer list. After uninstalling SCP, reinstalling, running the clean wipe utility, trying the latest betas, etc, I found this:
https://github.com/nefarius/ScpToolkit/issues/558

Apparently a new version of the DS4 is being sold (it looks the same) and is not supported by SCP. The part number on my old DS4 is CUH-ZCT1U, while the new one is CUH-ZCT2U.

Is SCP no longer being updated? The last beta release was Apr 12, 2016.

Is there any way to use both the old and new DS4 together with a DS3 controller?

Thanks

Edit:
I originally had the betas installed but thought it was the stable release. The betas don't work with the new DS4, but the stable release does.
Reply
This program deleted my mouse and keyboard controls? help?
Reply
Result of Gamepad Analyzer for my not recognized controller:


Attached Files
.txt   PS3 Wired Gamepad_hid-report.dump.txt (Size: 3,57 KB / Downloads: 21)
Reply
Hello,

I thought I installed everything correctly but the controller still doesn't work.  It works fine on my laptop, but not on my desktop.  Both are windows 7, laptop has older version 1.2.0.160 (which I also tried on the desktop but it would bsod when trying to install the drivers) the desktop is using v1.6.238.16010.

It shows it is connected but I have no idea why it won't show in the Game Controllers window.  I almost remember having it work on the desktop but now it doesn't.
[/url]
[url=https://github.com/nefarius/ScpToolkit/releases/tag/v1.6.238.16010]

             
Reply
Thank you Nefarious for your software! I've been using scptoolkit for a while now and all has been great UNTIL... this new windows creator update.  Due to some blue-screens and other nonsense, it is impossible for me to backtrack.  Now, my controller just doesn't seem to work.  

Results from ScpToolkit Debug Info Collector:

"Enumerating USB devices...
ERROR: Exception has been thrown by the target of invocation."

No idea what it means, but I can't open the driver-install app.  It said to check the log, but I don't read code.  I've attached the log.  

Please help/patch!

ixflqr

(and seriously, kudos for your work!)

Edit- durr PS3 controller fyi

Edit 2- Problem mostly solved: I went to device manager, deleted the driver AND clicked the little 'completely remove' button (or something similar). Re-plugged in, SCP reg process, hey! magic. Just working with getting services not auto-declined now. Hope this helps someone.
Reply
Here is a game pad that has been analyzed with the game pad analyzer that should be given SCP functionality.


Attached Files
.txt   _hid-report.dump.txt (Size: 78 bytes / Downloads: 19)
Reply




Users browsing this thread: 10 Guest(s)