Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Screen shaking on Panzer Dragoon
#1
Hi everyone,

As other people have reported long before me, on Panzer Dragoon there is a huge headache inducing screen shake. 
No matter which video mode (dx9/11/opengl/software/hardware) or interlacing mode used, the screen shake is always there sadly.

I got the original japanese disk "sega ages 2500 vol.27: panzer dragoon", so I was able to test the game in different plateforms:
- PCSX2 (stable and nighly, so many versions tested) -> screen shake
- PS2 emulation on PS3 -> screen shake
- real PS2 -> no screen shake
So it appears that the PS2 emulator on PS3 has the same issue strangely, which might means that the game uses the real PS2 hardware in a tricky way...

Is there any way to patch the image or force the video mode the might fix the issue?

Thanks Wink
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
Reply
#3
The hardware I tried on:
First PC:
i7-3770K
32GB of RAM
NVidia 1060
Windows 10 x64
Second PC:
i5 2320
4GB of RAM
AMD radeon HD 7850
Windows 7

For the other information, everything is already written in my post (was it an automatic answer?), but just to make sure everyone can read it:

For the version, as I mentioned I tried several, both nightly and stable, I tried probably around 30 different builds in the last 2 years, from the builds back then to the most recent ones. But if you want a specific build, let's say the stable 1.4.0 and Dev 1.5.0-2323

All the settings are in default (resetted to default few times), and as I already said I tried to change the video mode, the interlace settings, and any other setting I could find but no improvement.

Again, as I said I have the original sega ages 2500 vol.27: panzer dragoon, so it's obvious I am using the disk, but I also made an image of my disk just to try, no change.

The shaking problem obviously doesn't come from the hardware, build, settings or type of support, but I'm no expert with PCSX2 itself, so that's why I can here to ask for help on how we could possibly make it work, like a specific memory hack or patch for the game or something Wink
I know some other games specific issues were solved that way so if somebody has any knowledge on how to implement such thing I would be really grateful Laugh
Reply
#4
The only setting I found that eliminates the shaking is setting the frameskip setting to constant skipping and Frames to Draw = 1 and Frames to skip = 0 (or 1). This isn't ideal as it introduces other issues. The game's native resolution shows 640 x 224 but automatically loads into progressive mode. It is a curious issue but beyond my knowledge.
Reply
#5
(03-18-2018, 12:04 PM)wheninrome Wrote: The only setting I found that eliminates the shaking is setting the frameskip setting to constant skipping and Frames to Draw = 1 and Frames to skip = 0 (or 1). This isn't ideal as it introduces other issues. The game's native resolution shows 640 x  224 but automatically loads into progressive mode.  It is a curious issue but beyond my knowledge.

Oh that's a clever trick, by skipping 1 frame you avoid the one misplaced Tongue
yes I think it has something to do with the video mode being forced to something the game doesn't support, which might be the case for the PS2 emulator on PS3 too Wink
I wonder if there is a way to force the video mode/frame rate in PCSX2, because changing the internal resolution doesn't seem to change the issue  Huh
Reply




Users browsing this thread: 1 Guest(s)