Screen tearing since newest PCSX2 dev builds
#1
Hello dear PCSX2-Team,

as the title says, there is a strange issue on the newest PCSX2 dev builds. Since i am sure that this report does not count as a bug report, i report it here to General Discussion and Support (Windows). I noticed this issue when i connected my laptop to my TV using an HDMI cable and started any game. But the laptop, laptop settings, PCSX2 settings, TV, TV settings and HDMI cable have not changed. I have never seen screen tearing on my TV when i connected my laptop to the TV and play a game with PCSX2 (not even with the older PCSX2 dev builds). I have tested twice the last working and first affected PCSX2 dev versions to be absolutely sure that this problem occurred at these. Now my question: Is this current result intentional, or is it an issue? You can still set the V-Sync setting to Standard in the PCSX2 settings to fix it, but before that there was no screen tearing even without V-Sync enabled. I have heard that enabled V-Sync can cause speed problems.

First affected PCSX2-Version: v1.7.2187 and above
Last working PCSX2-Version: v1.7.2186 and below

Thank you in advance for your answers. Laugh
Reply

Sponsored links

#2
It looks like in full screen mode at least, that it's disabling the windows DWM now, which is a good thing for input lag, but unless you have a Variable Refresh Rate monitor (Freesync/GSync) then it will tear, so you will need to enable vsync in the options.

tbh that's how things *should* be, but we've been stuck with not having any option for years.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
I see. And is V-Sync currently still a major speed issue for PCSX2, or can i enable this setting „almost“ without problems? That should have been my last question on this thread. Smile
Reply
#4
well enabling VSync shouldn't be much different to previous behaviour, maybe except a limit to the framerate based on your refresh rate (when fast forwarding)

if that's not the case, we need to know what's wrong so we can look in to it.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
I really thank you very much for these quick answers. If anything catches my eye, i will try to get back to the forum, maybe in a extra thread.
Your work is still wonderful, everything is getting better and better. Respect to you ALL. Smile
Reply
#6
(01-03-2022, 10:51 PM)refraction Wrote: It looks like in full screen mode at least, that it's disabling the windows DWM now, which is a good thing for input lag, but unless you have a Variable Refresh Rate monitor (Freesync/GSync) then it will tear, so you will need to enable vsync in the options.

tbh that's how things *should* be, but we've been stuck with not having any option for years.

Do you mean "Wait for vsync on refresh" setting? I tried both Adaptive and Standard but the tearing doesn't go away.
Reply




Users browsing this thread: 1 Guest(s)