Segmentation issue after memory card intro
So I start the game, it asks if I want to continue without a memcard. When I say yes quits, stating:

ZZogl: Disabling MRT depth writing line 2: 4066 Segmentation fault ./pcsx2

I have seen others post similar questions and everyone says it is an issue with the zzogl but I am not exactly sure how to deal with this. I followed Zedron's instructions to git clone and I now have a zzogl file. I am kind of new to programming and am not sure what to do with this file, I assume compile it ? I did something similar with php and python builds but I followed some instructions and can't seem to find the information I need.

I could also be entirely on the wrong track and I would really appreciate any assistance.

Good news is my PS3 controller is working!

I have a Macbook Pro 2.66 GHz Intel core 2 duo and my PCSX2 is built following the instructions given on the website, with ZZOgl 0.21.204 and ZeroSPU2 0.4.6


Sponsored links

#2 I tried to compile the zzogl that I got from Zedrons repository using cmake, which seemed like the right way to go because of the cmake.txt files. However, it didn't work and stated that there were errors in the process:

Configuring ZZogl 0.21.213
checking for x11... yes
CMake Error at CMakeLists.txt:100 (message):
pkg-config not found, need it to find gtk libs, aborting...

Would really appreciate some assistance from one of you gurus 8)
Well, obvopusly CMake need something named pkg-config. In linuxes, it is pakage: pkg-config - manage compile and link flags for libraries. Read
Thanks for the response Zeydlitz! Unfortunately, I am having a new set of issues. First the Darwinports site with pkgconfig has been relocated, and I had to install Macports, then pkgconfig. Then I ran Cmake again and got a new error:

checking for module 'gtk+-2.0'
package 'gtk+-2.0' not found
CMake Error at /Applications/CMake (message):
A required package was not found
Call Stack (most recent call first):
/Applications/CMake (_pkg_check_modules_internal)
CMakeLists.txt:106 (pkg_check_modules)

CMake Error at cmake/funcs.cmake:32 (message):
gtk not found, aborting...
Call Stack (most recent call first):
cmake/funcs.cmake:23 (reportFound)
CMakeLists.txt:107 (checkFor)

Configuring incomplete, errors occurred!

SO...I then proceeded to install the gtk module...

Then I got the same error still. Someone on stackoverflow told me to check if pkgconfig is found by gtk correctly by: pkg-config --cflags gtk+-2.0

It was. Then I reinstalled Cmake via command line as per advice given and I still ended up with the same error.

Is there not an easier way for me to update zzogl?
First, open CMakeList.txt and loo at line 106. Second, there should be subdirectory with name cmake with file that have name of all required libraries. For example, it could be FindGTK.cmake.

Well, I use simple buildscript and makefile hell.
Erm, I don't really recommend inexperience people to compile from source. First thing, recompiling it won't actually help by itself Smile

MacPorts/DarwinPorts won't work, everything should be compiled from scratch manually. Some gtk versions for example are just incompatible, general mac weirdness. There's also a couple of steps where you need to manually modify the header files.

Users browsing this thread: 1 Guest(s)