Shadow Hearts 2: Covenant
Everything works perfectly except the battle sequences. When the rotating circle comes up to attack, the bottom half of the screen is black(the entire screen goes black in uses of some different BIOS versions).
Otherwise, everything else works perfectly.

Here are my specs:
Intel Core 2 Duo E7400 Wolfdale 2.8GHz
Radeon HD 4870 1GB 256-bit GDDR5
4 Gigs of RAM
Vista 64 bit

Using these plugins:
GSdx 890 SSE3 [10 02 2009]
LilyPad 0.9.9 [06 02 2009]
Linuz Iso CDVD 0.8.0 [20 02 2009]
USBnull Driver 0.5.0 [15 04 2007]
SPU2ghz Playground 1.9.0 [05 12 2008]
DEV9null Driver 0.3.0 [15 04 2007]
FWnull Driver 0.4.0 [16 05 2005]
USA v02.00(14/06/2004) Console
DC and MTGS | VU1Rec and VU0Rec | rCache 0 | Console 1 | Patches 0

Strangely, if I change the graphics settings to software gdx10 instead of hardware gsdx10, the graphical glitch is gone. However, the game runs much slower in this software mode.
Any ideas?

Sponsored links

Try use PCSX2 Beta 1059 and use Gsdx r1164 SSE3.
(note: you can try use the DirectX9 then DirectX 10 because certain game work well with the DirectX 9 then 10)

Can post the screen shot regarding the graphic glitch ?
i just tested that game the other day and i have exactly the same problem you do. Didn't found any solution though... -_- . It's not that big of a deal, so i just ignored it =P.
[Image: fs.png]
Q9550 @ 3,33GHz Ninja
HD 3850
Thanks nelsonz. Fixed it.
I used the newest gsdx(i think sse4 though, i forget), that seems to fix the problem. Still using pcsx2 0.9.6 though.

Seems to run perfectly now. Without speedhacks, stays near 100% fps nearly all the time, with some dips in frame rate in one area. I haven't played much yet, but seems fully playable and mostly full speed so far.
Hm can't seem to get it to work here...can you state your GSdx revision,settings used and region of the game?
[Image: newsig.jpg]
Only way i got it to work was to use DX10 software mode, software mode actually gives a decent speed in that game.
Oh right,should have been more clear,I was asking for a way to make it work in Hardware Wink Anyway it is really minor so I don't mind much
[Image: newsig.jpg]
i asked this before a long time ago and its a known problem and no way around it currently. I tried every setting, every gsdx, so i just stuck with SW mode. But like you said its a minor glitch wont take away from the game itself.
Hmm, wow I didn't even realize it, but the setting for software mode was saved from a previous attempt at fixing this. I'm using GSDx 1161 SSE41 0.1.15.
When I tried software mode before, the frame rate was unbearable, but now the game is running at a stable 60 frames per second most of the time, even in 1920 x 1080.

Has anyone tried using the beta pcsx2?

If anyone figures out how to fix the glitch in hardware mode, please share Smile

EDIT: Hmm, wow I just realized hardware mode looks much better than software mode. The edges on characters and whatnot are terrible in software mode
Here's a screenshot of the glitch:
Of course Software looks terrible compared to Hardware since it is rendering at the game's internal resolution (512x512 probably). In Hardware mode you can see that the internal res boxes can be changed,thus changing the resolution the game is rendered at.
The other resolution drop down box is just the size of the window,not what the game will be rendered at Wink
Since it works in SW mode,it means it is a GSdx plugin bug so only a new GSdx would fix it,but I wouldn't count on it since the issue has been known for a long time now
[Image: newsig.jpg]

Users browsing this thread: 1 Guest(s)